Support » Plugin: Giftable for WooCommerce » Gift Not Added to Cart

  • Resolved nicoleflex

    (@nicoleflex)



    The gifts appear on my cart page, however they do not add to the cart.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Word Press Version 4.8.1
    WooCommerce Version 3.1.2
    Theme: Peddlar

    Plugin Author DecomTeam

    (@decomteam)

    When you test -> disable Cache (Clear all cache, OP cache etc.)
    – You shouldn’t cache CART & CHECKOUT pages
    Configuring caching plugins
    —————–
    Did you try a different theme?
    Do you have auto add to cart or custom AJAX functions?
    —————–
    Minimum PHP version is 5.6

    [ Signature deleted ]

    • This reply was modified 11 months, 3 weeks ago by  Jan Dembowski.

    I have the same problem. Gift products appear on Cart as they should, but all “Add to Cart” buttons are grey. Disabled.

    • I disabled my cache plugin (Comet Cache)
    • I disabled my previous gift plugin (WooCommerce Multiple Free Gift)
    • PHP version IS 5.6
    • WP version 4.92
    • Woocommerce 3.3.0
    • WP Theme is WooCart

    Nothing helps.

    I even started to wonder, if the huzzle might have something to do with this:
    WC 3.3: Issues with Categories displaying in Shop

    As you must know by now, that latest Woocommerce upgrade is a mess. One problem is those dated theme files, e.g. cart.php. Right now I’m waiting for my WooCart theme fixing update.

    • This reply was modified 9 months, 3 weeks ago by  yesper.
    • This reply was modified 9 months, 3 weeks ago by  yesper.
    Plugin Author DecomTeam

    (@decomteam)

    When new update is released, give it a couple of days before you update.

    Maybe they will fix it in next release 3.3.1 – right now they are adding “disabled” on all buttons on cart page, you can fix it by removing “disabled” from all “giftable” buttons with jQuery.

    
    <script>
    if ( jQuery( '#dgfw-gifts-carousel' ).length ) {
        jQuery( '.dgfw-gift' ).each(function( ) {
            jQuery( '.dgfw-add-gift-button, .dgfw-select-gift-button' ).prop( 'disabled', false);
        });
    }
    </script>
    

    I usually wait a week or two, before updating. But not this time. 🙁

    And yes, my theme developer already replied; they are workin’ with the update. We’ll see.

    – – –
    This workaround looks nice. But where it should be added? — functions.php?

    Oh no. The page.php? Header section?

    • This reply was modified 9 months, 3 weeks ago by  yesper.
    • This reply was modified 9 months, 3 weeks ago by  yesper.
    Plugin Author DecomTeam

    (@decomteam)

    Best way would be to add it to theme files (JavaScript) custom-name.JS,
    or you can use plugin like Custom CSS & JS:
    https://wordpress.org/plugins/custom-css-js/

    *you can just open footer.php and paste the code just before </body>

    Thx for your quick reply.

    I tried the easiest one and pasted the code in footer.php.

    No luck. Nothing changed. Still grey buttons. 🙁

    Plugin Author DecomTeam

    (@decomteam)

    Could you open your thread/topic and post url to your shop?
    If shop isn’t public, please send us a support ticket to support [at] decom.ba

    *I hope you pasted the full code with “script” part also, and you cleared the cache?

    And, one for the road. 😉

    I used the plugin WP Rollback, and (quite easily) managed to get back the previous WooCommerce version (3.2.6). That resolved the Gift problem too.

    So far, so good. Thx!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Gift Not Added to Cart’ is closed to new replies.