Support » Fixing WordPress » .GIFs no longer resize to thumbnail after upgrade

  • Hi,

    Ever since upgrading to WP 3.5, .gifs are no longer being re-sized correctly to thumbnails on the homepage, categories pages, and archive pages of my site (everything worked before upgrading). .JPGs and PNGs are fine, though.

    I have these settings under Settings>Media:
    Crop thumbnails to exact dimensions checked
    Organize into month and year folders.

    I am using the same exact theme and settings that I was using before upgrading.

    I have tried deactivating all plugins and there seems to be none that are conflicting. I have tried the Regenerate Thumbnails plugin numerous times over the past two days and that hasn’t helped either. I have tried uploading the same image (as .gifs) using the Featured Image option within posts, but that doesn’t work. However, if I upload the image again as a .JPG or .PNG, then it re-sizes correctly.

    Examples can be found on the homepage here: (scroll down as the very last post is one that will not re-size to 150×150 and I have no idea where the thumbnail dimensions for this image are even coming from?).
    And here:

    The one and only instance I can find where a featured image (that’s a .gif) is actually resizing to 150×150 on an archive page is here (the very top image): That photo is used as an image within the post as well and the original is 300×300.

    Thank you in advance!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Did you ever find an answer? Having a similar issue with wp-ecommerce product images. jpg works fine, but gif images do not generate thumbnails. Also using Eventbrite and all gif event images are now broken. It was all good prior to updating.

    Hi lbrocka,

    Unfortunately, I never did find an answer to this issue. I even changed themes, thinking that was where the problem was, but I still have the same problem. I am slowly making my way back through and converting the images to .jpgs here and there when I have spare time.


    Thanks for the reply! I haven’t found an answer either. Thought it might be a problem with wp-ecommerce but it’s not only product images, it’s any larger gif Thought it might be a time out error, but increasing memory limit and regenerating thumbs didn’t fix it. Frustrating!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘.GIFs no longer resize to thumbnail after upgrade’ is closed to new replies.