Support » Plugin: Gravity Slider Fields » GF_Field:GF_Field::get_conditional_logic_event is deprecated

  • Resolved joelmelon

    (@joelmelon)


    hey, thanks for creating this plugin.

    sadly i cannot get it to work. if i add a slider field to the form, i get this notice in the backend:

    Notice: GF_Field:GF_Field::get_conditional_logic_event is <strong>deprecated</strong> since version 2.4 with no alternative available. in .../wp-includes/functions.php on line 4438 on line 4332

    any ideas? thanks in advance!

Viewing 6 replies - 1 through 6 (of 6 total)
  • +1 same here!

    Plugin Author uamv

    (@uamv)

    Thanks for reporting this! I’m now seeing that notice, too. However, event though it is currently throwing this notice, that alone shouldn’t prevent proper functioning of a slider field, I think. Though, I expect it may mess with conditional logic.

    @joelmelon are there specific things you’ve found not functioning?

    I’ll look to issue a fix for this deprecated function.

    Everything works in the preview. However, the error message prevents me from including the form in Thrive Themes. Apart from that, it doesn’t look very trustworthy on the page either.

    Thread Starter joelmelon

    (@joelmelon)

    @uamv it really seems to work anyway. as @mbarretobittner mentioned, it doesn’t look very trustworthy 🙂

    one more thing, if i enter a value for value relations and update the form, it is no longer possible to edit the slider field. maybe this error is related to this notice?

    It actually does break the conditional functionality. The slider field cannot be used as an input for a different field.

    Plugin Author uamv

    (@uamv)

    The call to this deprecated function has been removed in version 1.6. Hopefully this fixes the issue.

    @top-node this notice is unrelated to the availability of slider fields in conditional logic. That’s not been available and I’ve not been able to build it into the plugin, yet.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘GF_Field:GF_Field::get_conditional_logic_event is deprecated’ is closed to new replies.