Support » Plugin: Google Analytics Post Pageviews » Getting Zero View counts for many posts

  • Resolved mymktp1


    Hi there,

    For some reason I’m getting Zero View Counts for many posts which doesn’t seem to be right. Some posts have only 1 view count which is not possible.

    1. I have followed all the steps including activating API for Analytics, been able set up API with Credentials, etc

    2. The plugin seems to be running fine with no errrors

    3. I added the php script into the post page or basically single.php but even so in Admin dashboard in all post the views aren’t displaying either as i have attached the screen cap here :

    I checked to see if there were API requests being made and there were… so I wasn’t sure what might be going on or what I might have done wrong?

    Hope you you could give me some advise 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author maximevalette


    Hello Kit,

    Maybe try to reset the cache, or try to use the PHP function to display the number in the posts themselves to see if there’s something more than just 0?


    Having same problem getting 0 value for many posts. Resetting the cache fix the 0 value for the posts but other posts getting 0 value now it occurs at random each time i try to reset the cache.

    Am using PHP function to display the number in the posts.

    Any suggestion how it might be fixed?

    I just installed this on a site that has 1,459 posts, and it is the solution I had been looking for, for displaying views on each post.

    Except, as described by others above, some posts — especially the most recent 50 or so — show zero views, even though they’ve been viewed many times. I am using the PHP function on the home page loop and the single posts. You can see the site at linuxgizmos dot com.

    What happens when you click the “empty pageviews cache” option? Does it clear all the counters to 0, and then refill them all over again? I tried it and it did not seem to do anything, and did not change the zeros showing up on the most recent posts.

    When I first installed and activated the plugin, I got an error from Google Analytics indicating that I had exceeded the allowed connections, or something like that. But it hasn’t happened since then.

    Great plugin, thanks!

    Following my use of the “empty pageviews cache” option, there are now page views showing up on all the posts I’ve looked at, so I think that solved the problem. Also, I read more of the previous support questions & answers, and now understand the problem with Google Analytics better. Perhaps the problem was due to it being the initial activation of your plugin on a site with about 1500 posts, and maybe it won’t occur again, since we only add several new posts per day.

    Plugin Author maximevalette


    Sorry for not replying but it looked like you found the answer by yourself 🙂

    Clearing the pageviews cache doesn’t set to 0, it just removes everything it already fetched before. I don’t see it as very useful except in rare cases if you want to test some things. It’s better to set a good value expiration delay.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Getting Zero View counts for many posts’ is closed to new replies.