Support » Plugin: W3 Total Cache » getting You do not have sufficient permissions to access this page. errors

  • Resolved creamofclubs


    do know i you can solve this little problem

    the plugin works ok but if try and enter my cdn details or go in to any other menu withing w3 i get You do not have sufficient permissions to access this page. errors.

    i have try deleting repleceing the .htacess and removeing all other files that w3 users but still get the same issue every time any ideas

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Frederick Townes


    Everytime you activate CDN you get this error?

    Hi Frederick,

    I’m getting this error too. I first noticed it today when I tried to export the media library which kept failing.

    When I go into the CDN Admin, I get the permission error.

    “You do not have sufficient permissions to access this page.”

    Weird that it happened all of the sudden.

    Found it. The plugin “Simple Admin Menu Editor” was causing the permission problem. All set now.

    Just to be more clear:

    The Simple Admin Menu Editor lets you hide menu items (handy of you have 60 plugins running like I do). When I went through and checked the items I wanted hidden, there were a few items within the “Performance” (W3TC) tab that had no names, so I checked them to be hidden. Turns out, those were the pages (CDN and db cache I think they were) that I wasn’t able to access and got the permission error for.

    Unchecking them fixed it.

    So, if you’re using the Simple Admin Menu Editor, and you’re getting permission errors accessing some parts of the W3TC admin, now you know why.

    We got this error message on our site too – It appears when we click on the Plugin tab in the main menu. We can still view “Add New,” “Edit,” and “Askimet Configuration” but not Installed Plugins. Very frustrating … It was working fine a few days ago. Any suggestions on how to fix this problem?

    hi Frederick I can access the the main w3 with no problem but if i try and access the any sub menus in w3 then i get the error.

    kceyedoctor and creamofclubs, are you running the Simple Admin Menu Editor plugin?

    Hi Curtis4 – no, we aren’t using the menu editor plugin. Also, we have several other sites, all with the same version of WordPress and the same plugins, and none of them are experiencing this problem. It’s very weird.

    Did anyone find a solution to this? I am having the problem now, only with w3tc, since I upgraded yesterday to 9.2.4.

    kceyedoctor, did you by any chance recently change the prefix on your WordPress tables? It would explain why you’re seeing this only on the one blog (since only that DB would be effected).

    In the usermeta table there are meta_keys called “wp_capabilities” for each user. That wp_, unfortunately, is defined by the prefix. For more information, check here.

    Apologies if that’s not the issue. That’s the only time I’ve encountered it in the last little while.

    To we haven’t found a solution yet, although I am definitely going to look into the Elieka’s suggestions … however, we did find a work-around. When we realized that we could still view “Add New,” “Edit,” and “Askimet Configuration,” we tried adding a new plugin. When WP was done downloading and installing it, there was a link to “Return to Plugin Page” … it worked! So, I copied the URL and can now access our plugins page by pasting it directly into the browser (after logging in, of course). It almost seems that there’s just a broken link in the main menu.

    It’s an annoying work-around, but it does work for us … maybe it will help you. Good luck!

    To Elieka: we didn’t intentionally change anything other than the content on our site, but it wouldn’t surprise me at all if something went wrong during the last WP update. Thank you very much for the info … we’re looking into it now.

    In my case, the plugin had not reactivated after I updated it.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘getting You do not have sufficient permissions to access this page. errors’ is closed to new replies.