WordPress.org

Support

Support » How-To and Troubleshooting » Getting White Screen of Death….can access WP-Admin,

Getting White Screen of Death….can access WP-Admin,

  • Weird situation. I have a site that is giving me the White Screen of death when I go to it. However, I can access wp-admin and login with no problem. I turned off all plugins and switched themes and nothing changed. Still white. Anything else I can do to solve the issue or figure out where the issue is?

Viewing 12 replies - 1 through 12 (of 12 total)
  • WPyogi

    @wpyogi

    Forum Moderator

    I don’t think so. My WP-Admin is running just fine. I see no warnings.

    esmi

    @esmi

    Forum Moderator

    Try checking your site’s error logs for messages. Your hosts should be able to help you accessing your site’s error logs.

    I just downloaded that esmi. I get messsage like this:

    [17-Oct-2013 12:39:02] PHP Fatal error: require_once() [function.require]: Failed opening required ‘./wp-load.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php:/usr/local/lib/php/PEAR’) in /home/yoursite/public_html/wp/wp-cron.php on line 26

    Line 26 is require_once(‘./wp-load.php’);

    But I have wp-load.php on the server. So why is this happening?

    I did a complete reinstall of 3.6.1 BTW. Now I can’t even login to wp-admin anymore. Just loops back to the login screen. Site still white.

    esmi

    @esmi

    Forum Moderator

    Try:
    – switching to the default theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder and the wp-config.php & root .htaccess files – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    OK, I renamed the themes folder and the site is coming back bare bones. So it must be something in the themes folder.

    esmi

    @esmi

    Forum Moderator

    Re-upload a fresh, unpacked, copy of the Twenty Thirteen folder to wp-content/themes using FTP or whatever file management application your host provides.

    Twenty Thirteen

    OK, so the good news is the site is back and it is my theme. But here’s where it gets weird. I decided to duplicate Twenty Twelve and gave it the name of the theme, Vibes. Changed all the comments in my theme (@subpackage, @since, Theme Name) like I usually do, uploaded the theme and activated. Did nothing else to the theme. It’s still essentially Twenty Twelve. Went to the site and what did I get? White.

    Mind you, the theme worked as Twenty Twelve. Twenty Thirteen worked too. All I did was change commented information. Why would this be happening?

    So I just duplicated Twenty Twelve into another theme. Uploaded it, activated it and right back to the White Screen. What?!

    Seems like all I can use is Twenty Twelve and Twenty Thirteen. Which is ridiculous. I’ve never seen anything like this before.

    esmi

    @esmi

    Forum Moderator

    My guess is that you introducing an error when you make these changes in the copied themes.

    I don’t think that’s it. There’s something weird going on regarding the server. Since both Twenty Twelve and Thirteen work, I decided to make a child theme using the One-Click Child Theme plugin and that did work. But only the style sheet took from the child theme. If I copy over the template files like header.php or index.php and make even the simplest change, those files are ignored and it uses the template files from the main Twenty Twelve theme.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Getting White Screen of Death….can access WP-Admin,’ is closed to new replies.
Skip to toolbar