WordPress.org

Support

Support » Multisite » [Resolved] Getting Warning messages during Network setup

[Resolved] Getting Warning messages during Network setup

  • rperezq

    @rperezq

    Hi,

    I am trying to set up a network, but after inserting the code in the wp-config.php file I star getting the foloowing messages:

    Warning: array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object in /home/rperezq/public_html/wp-includes/theme.php on line 499

    Warning: Cannot modify header information – headers already sent by (output started at /home/rperezq/public_html/wp-includes/theme.php:499) in /home/rperezq/public_html/wp-includes/pluggable.php on line 934

    I changed the active theme to the default WP, but the messages persist.

    Could you please support me with this issue?

    Thanks

Viewing 14 replies - 1 through 14 (of 14 total)
  • rperezq

    @rperezq

    I also installed the Enable Multi-Site Pluggin. The only thing I have not done is changing the Apache Settings as outined in:
    http://jgwebdevelopment.com/plugins/wordpress-multi-site-enabler-plugin/wordpress-multi-site-information/

    Thanks again,

    Roberto Perez
    http://www.robertoperezq.com
    P.S. You may notice that if you click my webpage, the error message appears above.

    Moderator Ipstenu (Mika Epstein)

    @ipstenu

    Did you turn off all your plugins before turning on MultiSite?

    rperezq

    @rperezq

    Ipstenu, thanks for your kind support.

    I turned some of them off. What should I do now?

    Roberto

    Moderator Ipstenu (Mika Epstein)

    @ipstenu

    All of them. Turn them all off. Every last one.

    rperezq

    @rperezq

    Shall I install the WP default theme and uninstall the third party themes also?

    Moderator Ipstenu (Mika Epstein)

    @ipstenu

    You don’t have to uninstall, just deactivate.

    rperezq

    @rperezq

    I’ve done everything exactly as instructed in the http://codex.wordpress.org/Create_A_Network webpage and the messages persist.

    I deactivated everything.

    Moderator Ipstenu (Mika Epstein)

    @ipstenu

    Where did you insert the code in your wp-config file?

    Do you have blank lines or spaces at the top or end of your wp-config.php file? That is OUTSIDE the line that are <?php and ?> at the top or end?

    rperezq

    @rperezq

    This is where I inserted the code:

    define (‘WPLANG’, ‘es_ES’);

    /**
    * Para desarrolladores: modo debug de WordPress.
    *
    * Cambia esto a true para activar la muestra de avisos durante el desarrollo.
    * Se recomienda encarecidamente a los desarrolladores de temas y plugins que usen WP_DEBUG
    * en sus entornos de desarrollo.
    */
    define(‘WP_DEBUG’, false);

    define(‘WP_ALLOW_MULTISITE’, true);

    /* INSERTADO POR RobertoPQ

    * define( ‘MULTISITE’, true );
    * define( ‘SUBDOMAIN_INSTALL’, true );
    * $base = ‘/’;
    * define( ‘DOMAIN_CURRENT_SITE’, ‘robertoperezq.com’ );
    * define( ‘PATH_CURRENT_SITE’, ‘/’ );
    * define( ‘SITE_ID_CURRENT_SITE’, 1 );
    * define( ‘BLOG_ID_CURRENT_SITE’, 1 );
    */

    /* ¡Eso es todo, deja de editar! Feliz blogging */

    /** WordPress absolute path to the WordPress directory. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);
    ?>

    rperezq

    @rperezq

    It’s actually commented out, but I remove the (*) and place the (*/) after the RobertoPQ when I want to activate the multisite back on

    There seems to be a plugin somewhere in your installation that’s calling the get_theme() function. For some reason, when it does call the get_theme() function, get_theme() is retrieving something other than an array when it calls the get_themes() function; which is causing the error you’re seeing.

    Make sure that, as ipstenu indicated, all of your plugins are disabled. Then, try switching to the TwentyEleven theme. If the error persists, try reinstalling WordPress manually to see if that fixes the issue.

    Moderator Ipstenu (Mika Epstein)

    @ipstenu

    It should look like this. Just to make sure. But what Curtiss said 🙂

    define('WP_ALLOW_MULTISITE', true);
    
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'robertoperezq.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    rperezq

    @rperezq

    Hi Curtiss,

    Thanks for your reply. I manually reinstalled WP and apparently it fixed the issue. I’ts working fine now.

    Thank you very much for your prompty and kind support.

    Roberto

    rperezq

    @rperezq

    Ipstenu,

    Thank you very much.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] Getting Warning messages during Network setup’ is closed to new replies.
Skip to toolbar