• Resolved egocefalo

    (@egocefalo)


    Hi, First of all, thanks for the plugin!

    I’m using it just to add a link at the end of every post. Since last update the link is not showing and the warning is popping up on every new post saving/publishing. After choosing “continue” the post saves/publish but the link is not added.

    Thank you

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Ajay

    (@ajay)

    Can you please explain to me how you’re adding this link? Any screenshots will be helpful.

    Thread Starter egocefalo

    (@egocefalo)

    Hi @ajay

    Of course, thank you, it’s here: https://ibb.co/DgPBF6f

    Thanks for your help

    Best Regards

    Plugin Author Ajay

    (@ajay)

    Thanks for this. I can confirm that there is a bug in the plugin on the content addition.

    Will you be able to test this beta version?
    https://github.com/WebberZone/add-to-all/releases/tag/v2.0.1-beta1

    On the actual adding/editing of the post, I think that might be a separate issue because my plugin doesn’t add anything to the edit screen of the posts. It directly hooks into the frontend when the post is displayed.

    • This reply was modified 1 year, 1 month ago by Ajay.
    Thread Starter egocefalo

    (@egocefalo)

    Hi @ajay

    It didn’t fix it.

    Plugin Author Ajay

    (@ajay)

    Do you mean that the content/link still isn’t added to the post output?

    Can you check that you’ve cleared any caching plugins if you have those enabled?

    Also, to confirm you can clearly see that the version is v2.0.1-beta1 when you go to the Plugins page in your Admin area?

    Thread Starter egocefalo

    (@egocefalo)

    The link shows, but the warning “Leave Site? Changes you made may not be saved” when publishing a new post remains.

    Plugin Author Ajay

    (@ajay)

    Can you disable my plugin temporarily and check this again? The plugin doesn’t tap into the Post Edit screen so it shouldn’t cause any issues to it.

    Thread Starter egocefalo

    (@egocefalo)

    Yes, as soon as I disable the plugin the problem dissapear and I am able to publish without problems. I made the debugging before opening this thread and since then the plugin has been disabled, published around 70 posts without the warning showed. I tried to publish twice after installing the beta and the warning showed.

    Thank you

    Thread Starter egocefalo

    (@egocefalo)

    It’s just when publishing, if I edit an already pulished post the warning won’t show.

    Plugin Author Ajay

    (@ajay)

    This is strange. Are you in a position to create a staging site for me that replicates these settings and I can check out?

    Are you using the plugin for anything besides the link? One thing worth trying if you haven’t done so already is make a note of all the things you’ve changed in settings and then completely reset the settings and add it back.

    Also are you using Gutenberg or the classic editor and is this issue you’re seeing on posts only or also pages?

    problem is I can’t replicate it at my end on all my sites.

    Thread Starter egocefalo

    (@egocefalo)

    I’m using the classic editor, it happens just on posts (which are the only ones with the link). I use the plugin just for that link, after I disable the plugin the only thing that changes on the site is that that link dissapear.

    I’ll check if I can set a staging site and come back to you later.

    Thanks for your help!

    Plugin Author Ajay

    (@ajay)

    I installed the Classic Editor and can confirm that there is an issue with adding new posts.

    Are you able to make one change in the plugin code and test?

    On this page: https://github.com/WebberZone/add-to-all/blob/v2.0.1-beta1/includes/admin/settings/class-metabox-api.php#L127 can you change the || to && and let me know if it works fine and if there are any issues.

    Thread Starter egocefalo

    (@egocefalo)

    Hi @ajay

    Yes, that fixed the publishing problem, the warning it’s gone. I also didn’t notice any other issue during and after publishing, I also enabled debug and no warnings or else arose from the plugin.

    Plugin Author Ajay

    (@ajay)

    Fantastic! Thank you for confirming. I’ll put this into the next bug-fix release. Likely later this week.

    Thread Starter egocefalo

    (@egocefalo)

    Excelent, thanks a lot for your help. And thanks again for the plugin.

    Best regards

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Getting the warning “Leave Site? Changes you made may not be saved”’ is closed to new replies.