Support » Installing WordPress » Getting started after installation

  • Hello everyone,
    I just installed wordpress and that was problem free.
    However, when I try to access it, I get basic elements like text links and the calendar, but no design elements and none of the links work. It looks nothing like the posted screen shots. Also, when I try to connect from another computer using a web browser, all links try to go to “localhost” instead of the actual ip address. This should probably appear in the installation area now that I think about it . . . sorry if this is the wrong location. Does anyone know what I should be checking?


Viewing 8 replies - 1 through 8 (of 8 total)
  • Firstly, ignore my last comment about placing this in the installation area!
    Secondly, I’m pretty sure I have “localhost” set somewhere it should not be.
    What files should I be looking at to fix this?

    Just look under Options > General in your the WordPress admin pages. There are two settings there, one for your blog’s url or address, and one for where WordPress is installed (these are often the same).

    Thanks Kafkaesqui!
    My fix was to install phpmyadmin and edit the path stored in the table wp_options at the record siteurl. Once I changed the record, everything worked.
    Thanks again for your help!

    What did you change it to? It might help me too.

    This is my second install (different computer).
    First install went without incident.

    Second install seemed to go fine, but the page that says ‘success! now log in’ takes me upon log in to a directory index. If I specifically type in the wp-login.php URL, I get another directory index.
    Not a bloggy look.

    I have phpmyadmin – please tell me what you changed wp_options to?

    siteurl = the url to WordPress*
    home = the url to your blog

    * This is usually the same as home, but some install WordPress into a different directory than their blog is located, hence the two fields.

    Thank you for the feedback.
    My siteurl seems correct:
    (I gather it can’t be localhost? which the auto-install chooses)
    I noticed the php scripts do not have execute permission.
    Oddly, they don’t have execute permission on the other Mac, where WP is working nicely. Not even for the owner. So I’m wondering why *that* is working.

    I changed it to the location of the index.php file. Make sure “localhost” is not part of that path and you are using either the ip address or the name.

    Doh! Solved. I can log in now and see the bloggy things.

    My problem was not a wordpress issue, but a PHP/Apache issue.
    index.php must be in the DirectoryIndex section of httpd.conf
    otherwise, and if indexing is enabled, if there’s no index.html page, you just get the directory index.

    My first (successful) WP installation was on OSX server. I think when I activated PHP through the GUI, it dealt with the DirectoryIndex. This second install is on OSX not-server, and it had to be handled manually.

    Still puzzled about permissions though. Seems like the scripts shouldn’t work, as no one has +x permission.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Getting started after installation’ is closed to new replies.