Support » Theme: Sydney » Getting ready for WordPress 5.0 & Gutenberg with Sydney Theme

  • Hi

    I’m just looking into things as many of my clients are based on your Sydney theme.

    How can I prepare myself for the dreaded new WordPress 5.0 Version coming out with Gutenberg ?

    How can I disable Auto WordPress updates to avoid this ?

    Will your theme have any issues with this ? I assume all Theme Developers and Plugin Developers are doing thorough testing at this stage in preparation for this new WordPress version which is completely different from previous and probably bound to break many sites.

    I hear I can install the Classic Editor Plugin also and install Gutenberg Plugin beta to test my sites on Beta version to see how much a site will break.

    What other suggestions do you have ?

    I need to start preparing my clients websites and to avoid a catastrophe !!

    I don’t have the Pro plugin but the normal one which I have always been happy with …

    Regards

    Kristin

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi

    I was hoping someone from the Sydney Theme Developers could offer some advice on the compatibility with Gutenberg with this theme and any other questions I had above.

    Thanks in advance !

    Kristin

    I am having trouble updating my pages, I reinstalled the classic version but still. not sure if this is related to the theme at all. Do you have any feedback please?

    I am having trouble updating my pages, I reinstalled the classic version but still. not sure if this is related to the theme at all. Do you have any feedback please?

    I replied you already in your other topic:

    https://wordpress.org/support/topic/wordpress-5-0-10/#post-10966546

    Regards,
    Kharis

    Hi

    I am still waiting on a reply myself with regards to my questions.

    If someone could help would be great !

    Thanks
    Kristin

    HI

    So I am guessing there may be some issues with Sydney theme and new Version of WordPress 5.1.1. ?

    I had not had a reply back to my original question 3 months ago?

    I am having fatal errors when updating plugins after upgrading my Sydney Theme in WordPress 5.1.1.

    Warning: require_once(public_html/domain/wp-content/plugins/wordpress-seo/vendor/composer/autoload_static.php): failed to open stream: No such file or directory in /public_html/domain/wp-content/plugins/wordpress-seo/vendor/composer/autoload_real.php on line 28

    This is just one of many errors when upgrading plugins.

    About 6 plugins cannot be upgraded due to Fatal errors after upgrading my Sydney Theme.

    I have done process of elimination leading to the Theme upgrade issue. I have many client sites using Sydney Theme so am a bit concerned and confused on how to fix the issue.

    I then tried to re-upload the original Sydney theme, that wouldn’t work.

    I know the current plugins that won’t activate due to the Sydney upgraded theme work no issues on other themes, only the Sydney theme is causing the issue.

    There was never any issue when on WordPress version 4.9.10 … and still worked on 5.1.1. WordPress version after upgrading that.

    So then I have tried different alternatives, upgrading the Sydney Theme BEFORE upgrading the WordPress site, and then doing it the other way around.

    Are there known errors/issues as per my original question and best way to resolve the issue with compatibility ?

    Thanks in advance

    Thanks
    Kristin

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Getting ready for WordPress 5.0 & Gutenberg with Sydney Theme’ is closed to new replies.