Support » Plugin: Yoast SEO » Getting PHP version warning on PHP 7

  • Resolved Lori Berkowitz

    (@bmonster99)


    Hi, I am getting the big PHP version nag warning in the dashboard that says to upgrade to PHP 5.6 or 7+, but the server is running PHP 7. How can I get Yoast SEO to recognize the PHP version? It would also be great if there was a way to dismiss this giant notice at the top of the dashboard. Thanks.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We understand the concern that the error message is not removable. The message was added as we want users to update because older versions of PHP no longer get security updates and PHP 7 is faster (which is good for SEO!).

    You can decide to upgrade the PHP to a more recent version or stick with the old version. If you do decide to stick with the older version the site will most likely be stuck with old versions of WordPress, as newer versions of WordPress will be requiring updated PHP. As the site is using older versions of WordPress this, again, may result in security issues as newer versions of WordPress contain fixes and older versions are not supported.

    These following guides explain more about the reasons for the message:

    These guides explain how to update if you desire:

    Thread Starter Lori Berkowitz

    (@bmonster99)

    Thank you, but my issue is that my server is already running on PHP 7 and I am still getting the warning.

    Plugin Support amboutwe

    (@amboutwe)

    The error notice is displayed when the server’s PHP version returns a value under 5.4 when we request the PHP version directly from the server. Please contact your webhost or server admin to verify that the PHP 7 update has been completed on the server for your website.

    Thread Starter Lori Berkowitz

    (@bmonster99)

    The server runs multiple PHP versions, and the hosting account is running PHP 7. The update completed successfully. Running phpinfo() shows the correct PHP version for the hosting account (7.0+). I do not know what PHP version the server runs by default, but the site with the Yoast warning is running PHP 7. Please either fix the plugin to recognize the correct PHP version of the hosting account, or allow people to dismiss the warning message.

    Plugin Support amboutwe

    (@amboutwe)

    I haven’t seen a false notification, yet, but would like to look into it for you. Would you be willing to provide the URL to a website that incorrectly shows the message and a link to the phpinfo file on that website?

    If you prefer, you may contact our support team with the information. Just mention this topic and my name (Angelia).

    In the future, we’ll let you dismiss the notice until the next update of Yoast SEO. You can find that feature request on GitHub here: https://github.com/Yoast/wordpress-seo/issues/7477

    Thread Starter Lori Berkowitz

    (@bmonster99)

    I will contact the support team with the information. Thank you.

    Thread Starter Lori Berkowitz

    (@bmonster99)

    The support link led me back here. Screenshots of the warning and the PHP info:

    Yoast PHP 7 warning

    PHP 7 info

    Same problem. I am running PHP 5.6.30, but that brutal obnoxious non-removable warning message is splattered across all my wordpress sites. Regardless of my website severs being above 5.4 anyway, these kinds of non-removable messages should never ever appear on a Dashboard. What were you thinking?

    FROM CPANEL:

    Server Information
    Item Detail
    PHP Version 5.6.30

    • This reply was modified 5 years, 2 months ago by pjc123.
    Plugin Support amboutwe

    (@amboutwe)

    @bmonster99 Can you provide us with more information about your server?
    Do you have any security protocols that mask or hide server information?
    Can you provide a link to the website in question and the phpinfo file so we can review other settings?

    Plugin Support amboutwe

    (@amboutwe)

    @pjc123 Please open a new request. That way it’s easier to track issues and provide assistance. When you open a new request, please include a link to your website and a phpinfo file. If you do not have a phpinfo file, please follow the steps here to add one to your site. Thanks!

    Thread Starter Lori Berkowitz

    (@bmonster99)

    No security protocols that I know of. It is a client’s site and I do not want to provide his information at this time. I also do not have time to troubleshoot this anymore. Please provide a way to dismiss the notice until the problem is fixed. Thank you very much for your time and help.

    Plugin Support amboutwe

    (@amboutwe)

    At this time, the message cannot be dismissed. In the future, we’ll let you dismiss the notice until the next update of Yoast SEO. You can find that feature request on GitHub here: https://github.com/Yoast/wordpress-seo/issues/7477

    @amboutwe. My issue is solved. It looks as if cpanel reports the maximum version of PHP that the server has, and I was actually at version 5.3 in WordPress, and it is up to the user to manually update PHP within WordPress. So I installed the PHP compatibility plugin and there was only a couple of errors and warnings with PHP 5.6 that had minimum impact on my sites, so I upgraded to 5.6, and now I can get security updates going forward. The warning message from Yoast is now gone, so that verifies all of this. PHP 7.0 had some errors with the compatibility check that would have likely been fatal, so I am skipping it until the plugin developers can catch up.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Getting PHP version warning on PHP 7’ is closed to new replies.