Support » Plugin: Analytics Insights for Google Analytics 4 (AIWP) » Getting PHP Parse error on wp-admin page

  • Resolved viniciusaac

    (@viniciusaac)


    Hi, first of all, thank you for you awesome plugin. It works fine, but only when I try to access mysite.com/wp-admin it returns an crash error. Can you help me to fix it?

    PHP Parse error: syntax error, unexpected ‘::’ (T_PAAMAYIM_NEKUDOTAYIM) on
    /analytics-insights/tools/gapi.php on line 74

    If i comment line 74 and 75, it works again.

    Thank you

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Alin Marcu

    (@deconf)

    Hi,

    What’s your site’s PHP version? You can check it under Tools – Site Health – Info – Server or Analytics Insights – Errors & Debug – System.

    Is it PHP 5.x?

    Thread Starter viniciusaac

    (@viniciusaac)

    No, it´s 7.4.11

    Plugin Author Alin Marcu

    (@deconf)

    The latest version should fix it.

    Please note that the error is PHP 5.6 specific. Your site is either on version 5.6, you’re installing via wp-cli which runs on PHP 5.6, or similar.

    Not 100% sure, but you should double check the above.

    Thread Starter viniciusaac

    (@viniciusaac)

    That´s funny, because I doubled check. From wordpress admin panel and Directly on server. Both returns php version 7.4.11. I will try to update it.

    PHP 7.4.11 (cli) (built: Oct 18 2020 19:39:05)

    Anyway, Thank you so much for your attention

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.