Support » Plugin: PayPal for WooCommerce » Getting Invalid Vendor error 26

  • Resolved senortim

    (@senortim)


    Everything works fine with v1.3.3, but after updating to v1.4.1, get the following error:

    PayFlow API call failed. Error Code: 26 Detailed Error Message: Invalid vendor account User IP: ***** Order ID: 2269 Customer Name: *** Customer Email: ***

    Rolled back to 1.3.3 and fine again. Note, using WooCommerce 2.6.14.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor angelleye

    (@angelleye)

    Hmmm…you’re getting this on 1.4.1, for sure? 1.4.0 had the issue, but 1.4.1 should not.

    I’m still getting the Error Code 26 as well.
    WC 3.0.5
    PayPal for WC 1.4.1

    Plugin Contributor angelleye

    (@angelleye)

    Okay, we’re digging deeper. We’ll get another update released ASAP!

    Thanks for the quick reply!! (And yes, sure about 1.4.1. We tried 1.4.0 but were experiencing the data-corruption error that 1.4.1 corrected.)

    Plugin Contributor angelleye

    (@angelleye)

    Okay, yeah, seeing some other reports of it, too, but I cannot reproduce the problem on our 1.4.1 update. Do you have any database caching tools enabled in WordPress or on the server directly you could clear out and then re-save the settings again?

    No database caching tools, no. By “clearing out” do you mean saving blank fields? Or is there another, preferred method? (Tool? Direct in DB?)

    Plugin Contributor angelleye

    (@angelleye)

    I mean clearing any caching / CDN services you may have in place in WordPress or on the server directly. Usually there would be a “clear cache” type of option somewhere.

    We’re looking into this on our end trying to reproduce it and get it resolved ASAP. Look for a 1.4.2 update soon!

    Hello,

    I “double” this request. Account was working fine until the update 1.4.1.
    My site uses “PayPal Payments Pro 2.0-PayFlow” and also “PayPal Express checkout”.

    I can pay using “PayPal Express checkout” but I can’t pay with my debit card using “PayPal Payments Pro 2.0-PayFlow”. The outcome is the “26-Invalid vendor account” error message.

    My PayPal account is linked with the same Debit Card I used trying to pay with the Payment card option (PayPal Payments Pro 2.0-PayFlow). So, there is no problem with this debit card.

    I just made LIVE payments (or attempts of payments) in order to be sure. And I did it after failed payments from clients!

    Something needs to be fixed asap, please.
    Thank you in advance, guys.

    Regards,

    • This reply was modified 2 years, 2 months ago by  oxley2016.

    Same here, Version 1.4.1 on WordPress 4.7.4, Virtue Premium theme, no CDN or caching plugins. Thank you

    PayPal Pro payment failed. Payment was rejected due to an error: (26) “Invalid vendor account” Order status changed from Pending payment to Failed.

    Plugin Contributor angelleye

    (@angelleye)

    We were able to get this fixed in the release branch on GitHub and it’s been verified by other users that were having the same problem. We will get our 1.4.2 update released very soon which fixes this and a few other things.

    If you need to get it working immediately you can download our release branch here: https://github.com/angelleye/paypal-woocommerce/archive/release.zip

    Just extract that zip and then upload all the files to your server overwriting the existing plugin files. This will fix PayFlow for you so you can take payments that way again.

    Sorry again for the mix-up on this!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Getting Invalid Vendor error 26’ is closed to new replies.