WordPress.org

Support

Support » How-To and Troubleshooting » Getting in /home4/gamingu1/public_html/wp-includes/SimplePie/Item.php

Getting in /home4/gamingu1/public_html/wp-includes/SimplePie/Item.php

  • I am getting this error showing up on our dashboard…

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 1966080 bytes) in /home4/gamingu1/public_html/wp-includes/SimplePie/Item.php on line 2736

    Yet when I go to that file and to line 2736, this is the code

    $thumbnails[] = $this->sanitize($thumbnail['attribs']['']['url'], SIMPLEPIE_CONSTRUCT_IRI);

    The file shows that it is something for RSS and ATOM Feed, yet it seems to be affecting the whole site. I am at a loss as to what to do and how to fix it. I dont know if or how this will effect the rest of the site. Its from a program called Simple Pie, do I need to get a hold of the developers or can someone help me here?

    Now that I look at what is installed, we do not have Simple Pie even installed as a plugin… could this be a plugin that was installed then removed, but somehow the file itself was never deleted?

    Any help will be greatly appreciated

Viewing 5 replies - 1 through 5 (of 5 total)
  • SimplePie is included with WordPress core. Are you importing an external RSS to your site?

    Moderator Jose Castaneda

    @jcastaneda

    THEME COFFEE MONKEY

    Have you tried deactivating all the plugins to see if that solves the issue?

    I realized after writing this that SimplePie is now included as it was showing up as a widget. I do not think I am importing an external RSS, I am assuming you are talking about putting another site’s RSS within the site?

    I have not deactivated all my plugins… let me do that and see what happens.

    I forgot to mention earlier that the error actual shows up in the WordPress News area on the dashboard.

    After deactivating all the plugins, the error disappeared. So I reactivated each plugin one at a time, and after each activation would refresh the dashboard, to see if the error would show up. It has not shown up again. So now I have no idea what was causing the error, but it doesnt seem to be showing up anywhere now…. I’m more confused than I was before.

    its a php memory limit thing,

    it it happens again, up your memory limit using php.ini, there are loads of examples on google

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Getting in /home4/gamingu1/public_html/wp-includes/SimplePie/Item.php’ is closed to new replies.
Skip to toolbar