Support » Plugin: Yoast SEO » Getting Images To Show In XML Sitemap

  • Resolved charliep127

    (@charliep127)


    Hello,

    I am trying to get all of my images on my posts to show in my sitemap so they can be indexed by google. I’ve noticed that the images are indexed when the src and href attributes in my post are the same but are not indexed when they are different (commonly due to re-sizing).

    For example, the following is indexed:

    <a href="http://s3-us-west-2.amazonaws.com/weathertogether.net/wp-content/uploads/sites/5/2018/09/201809232100_500mb.gif"><img class="wp-image-8827 size-full" src="http://s3-us-west-2.amazonaws.com/weathertogether.net/wp-content/uploads/sites/5/2018/09/201809232100_500mb.gif" /></a>

    On the other hand, this is not:

    <a href="http://s3-us-west-2.amazonaws.com/weathertogether.net/wp-content/uploads/sites/5/2018/09/201809232100_500mb.gif"><img class="wp-image-8827 size-medium" src="http://s3-us-west-2.amazonaws.com/weathertogether.net/wp-content/uploads/sites/5/2018/09/201809232100_500mb-300x223.gif /></a>

    I’d like to avoid displaying the full-sized image on my blog posts because it increases loading times. Can I display the smaller versions that WordPress creates and still have them indexed so that search engines can find them?

    Thank you.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Michael Tina

    (@mikes41720)

    Could you please provide the URL of which post this is in your post sitemap of the Sitemap Index?

    Hi Michael,

    It affects all posts, but here’s the one I was referring to specifically.

    http://charlie.weathertogether.net/2018/09/24/warmest-weather-this-week-for-at-least-six-months/

    The only images that are indexed are the featured image (the colorful satellite image at the top) and the University of Washington satellite image, and that is because these are the “originals” that were directly uploaded (whether it is the “full-sized” UW Satellite image or the featured image that was created by the theme).

    The other images in the theme (including the un-cropped colorful satellite image that is the same as the featured image) are not indexed, and this is because the images displayed on the page are not the ones directly uploaded… rather, they are the “large,” “medium,” etc. versions of those.

    Plugin Support jerparx

    (@jerparx)

    @charliep127 We are not certain of that behavior. We are unable to reproduce it in our test environment. Can you please provide us with a step-by-step guide on how you resized those images that were not included in your sitemap so we can try to replicate the issue from our end?

    1.) I upload the image to the wordpress media library
    2.) WordPress automatically creates the “thumbnail,” “medium,” and “large” image sizes according to the dimensions I’ve specified in my dashboard under settings->media.
    – Note: for (1) and (2)), the pictures are uploaded locally to my site.
    3.) These images are copied to my Amazon S3 bucket using the WP Offload Media Lite plugin, and the image URLs are rewritten altered so that they point to the bucket.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Unfortunately, we’re not aware of such issues with the Yoast SEO plugin. We looked at your post sitemap and we can confirm that Yoast SEO is generating all the images URLs correctly to ensure search engines can crawl them. It is still up to search engines to crawl the submitted items. We recommend you please monitor your Google Search Console property to see if you can find anything specific to this issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Getting Images To Show In XML Sitemap’ is closed to new replies.