Support » Plugin: SiteGround Optimizer » Getting ‘HTTP error’ when uploading new images

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @tristandenyer

    The issues is because the server memory/time limit is reached when you try to upload big pngs.

    We know about it and we will try to fix it in the next version.

    Regards,
    Stanimir

    Instead of starting a new thread I thought I’d chime in here.

    I am running SG Optimizer in a staging environment, but that should not make a difference, right? I first cloned a barebones WP install and am building a brand new site all in staging. That means SG OPtimizer only exists in the staging site right now.

    ‘Optimise existing images’ has been running for several hours now, and there were only about 50 photos when I started it, a mixture of .png and .jpg each not more than around 400k.

    My big question is how do I give up and stop it? Is there a particular reason that we can only pause and not abort the optimise process?

    Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @sean-h,

    You can pause the image optimization, because it stuck for some reason. With 50 images it should finish for minutes. The functionality rely on cron jobs, which are executed when the website is visited. I guess that since this is a staging site it has no visits, which means that the cron jobs are not executed.

    We will improve the image optimiztion in the next version and we will consider your suggestion to add “Stop” button.

    Regards,
    Stanimir

    Thanks for the quick reply Stanimir.

    I have visited the site a few times myself, because I know of the cron job situation, but that doesn’t seem to help. What about .png’s? I read somewhere people are having problems with those?

    To be honest, most of the png’s are downloaded from Divi templates and are going to be deleted soon anyway. What if images are deleted while image optimisation is still busy, or stuck in this case? What if I delete SG Optimiser from the staging site and re-install it on the staging site? Will the optimise process automatically try restarting? or will that action kill it?

    I am also considering deleting SG Optimizer from the staging site, and only installing it fresh on the live site after I push the staging copy there. It is a brand new site with only a single coming soon page on the live version.

    Hope I haven’t broken any rules by hijacking this thread, but I figured it was more or less related. My small issues with Wordfence in staging are for another thread.

    Hi @sstoqnov,

    Do you know when the new version/fix will be released?

    I found that by turning New Images Optimization off, I was able to upload png files.

    Would an alternative option be to add a function in SG Optimizer that allows new images to be scanned at selected intervals, rather than during upload?

    Matt

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Getting ‘HTTP error’ when uploading new images’ is closed to new replies.