Support » Plugin: PayPal for WooCommerce » Getting HTTP ERROR 500 when navigate to woocomerce->setting

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor angelleye

    (@angelleye)

    This is most likely happening because you are running on an old version of PHP.

    Our plugin requires PHP 5.3 or higher. If you check the PHP Supported Version history you’ll see that 5.3 and 5.4 have both reached “end of life” and are no longer supported. 5.5 is going to reach the same status in about a week.

    So it’s really recommend that you get your site updated to use PHP 5.6 or higher. Your host should be able to help you with this.

    You can verify that you’re running an old version of PHP by loading up phpinfo() in a page on your site. Just create a phpinfo.php file with nothing but this in it:

    <?php
    phpinfo();
    ?>

    Upload that to your server and load it in a browser. It will show your current PHP version at the top.

    Hi I get a similar error, when I want to go to the settings after activated the plugin it shows me:

    Fatal error: Class ‘WC_Gateway_PayPal_Credit_Card_Rest_AngellEYE’ not found in /web/htdocs/www.bwracing.it/home/wp-content/plugins/woocommerce/includes/class-wc-payment-gateways.php on line 105

    Can you help please? Is it also a PHP issue?

    Ok resolved.

    Plugin Contributor angelleye

    (@angelleye)

    @bwracing, did you update your PHP version to solve the problem?

    Yes, I updated the version to 5.6.19 and than it was working. Thks

    Plugin Contributor angelleye

    (@angelleye)

    Thanks for verifying!

    Thread Starter sampibiz

    (@sampibiz)

    Hi,

    I forgot to update that I also updated to a new version of PHP, and it was resolved.
    Great plugin!
    Thank you!

    Hi,
    I have the same problem and the php version is 5.6.24: http error 500 after I click on the payment button using the PayPal Express Checkout mode. The page url is domain.ext/?wc-api=WC_Gateway_PayPal_Express_AngellEYE&pp_action=expresscheckout

    • This reply was modified 5 years, 7 months ago by francescor.
    Plugin Contributor angelleye

    (@angelleye)

    @francescoro What version of WooCommerce are you running? Can you check your PHP error logs to see what the actual error is that is happening?

    I’m using the latest version of Woocommerce: 2.6.14

    • This reply was modified 5 years, 7 months ago by francescor. Reason: 2.6.14
    Plugin Contributor angelleye

    (@angelleye)

    What about PHP error logs? Any information there for us?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Getting HTTP ERROR 500 when navigate to woocomerce->setting’ is closed to new replies.