WordPress.org

Support

Getting fatal error.

  • I installed and tried to use, but when I go to the Post that has the gallery, I am getting a fatal error that says:

    Fatal Error (hide details) (remove)
    The site encountered a problem that it cannot recover from. Please use the following information to try to resolve the problem.

    Error Message

    Fatal Error: Class ‘Jetpack_Options’ not found in /home/xxxxxx/public_html/xxxxxx/wp-content/plugins/tiled-gallery-carousel-without-jetpack/jetpack-carousel.php on line 249
    Description

    The Tiled Galleries Carousel Without Jetpack plugin code created an error that caused PHP execution to fail.

    The code tried to use a PHP class that doesn’t exist (Jetpack_Options). This type of error is typically caused by a simple typo (WP_error rather than WP_Error), by trying to use a class that is provided by a plugin when that plugin is not activated, by trying to use a class before it is ready (such as trying to use a class before the code that creates it has run), or by trying to use a class that no longer exists (the class may have been removed from WordPress core or the plugin/theme that previously supplied it).

    Help?

    Gary

    PS: I am running WP 3.8 and v1.2 of this plugin.

    http://wordpress.org/plugins/tiled-gallery-carousel-without-jetpack/

Viewing 8 replies - 1 through 8 (of 8 total)
  • You can comment that line out, but it will dissapear if you select a gallery type in the gallery editor (where you can define if you want circles, thumbnail grid, tiled mosaic, etc)

    Thanks. But I guess I was hoping that the plugin could be updated as to avoid the issue, rather than my commenting a line out. I appreciated (very much) your comment. Hopefully the developer can fix this issue with a permanent update.

    Gary

    Hi.

    Sorry if I didn’t make it clear: To avoid that message, you just have to select one type of gallery in the right column, and it will dissapear.

    I’m getting the same error code, but my “type” selection is missing upon creating a new gallery. I also have no option in Settings>Media for any of the various types.

    WordPress v3.8
    Tiled Gallery Carousel Without Jetpack v1.2

    Also getting the error and cant seem to find any options to change the gallery “type”

    WordPress 3.8.1

    I had this problem too until I checked the box in Settings -> Media to ‘Display all your gallery pictures in a cool mosaic’. After checking that, the error went away and I could choose the type of gallery when editing a gallery.

    I have the same problem, dosent mather if I select a gallery type and check the box in settings. 🙁

    I’m having this same problem, tried the solution by echoleaf and it did not work for me either. I am wanting to use a regular thumbnail gallery on a page (all other types work without getting the error).

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Getting fatal error.’ is closed to new replies.
Skip to toolbar