Support » Plugin: EWWW Image Optimizer » Getting errors while optimizing

  • Resolved webguru4u

    (@webguru4u)



    Hi

    I have a huge blog with over 10,000 images. I am optimizing them manually in media library- 400 at a time. It optimized half of the images successfully but when I am at page 15 of media library and all subsequent pages, it shows this error in the “image optimizer” column-

    [ Moderator Note: Please post code or markup snippets between backticks or use the code button or log data. ]

    ===================
    Warning: getimagesize(/home/xxxx/public_html/mysite.com/wp-content/uploads//var/www/vhosts/mysite.com/httpdocs/wp-content/uploads/2007/08/imagename.jpg) [function.getimagesize]: failed to open stream: No such file or directory in /home/xxxx/public_html/mysite.com/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 1890
    
    Warning: filesize() [function.filesize]: stat failed for /home/xxxx/public_html/mysite.com/wp-content/uploads//var/www/vhosts/mysite.com/httpdocs/wp-content/uploads/2007/08/imagename.jpg in /home/xxxx/public_html/mysite.com/wp-content/plugins/ewww-image-optimizer/ewww-image-optimizer.php on line 1904
    Unsupported file type
    ===================
    
    When I still try to optimize them by bulk selecting the images, it returns this error for each image-
    
    ===================
    Optimized image: /var/www/vhosts/mysite.com/httpdocs/wp-content/uploads/2007/08/imagename.jpg
    Full size – Could not find /home/xxxx/public_html/mysite.com/wp-content/uploads//var/www/vhosts/mysite.com/httpdocs/wp-content/uploads/2007/08/imagename.jpg
    Elapsed: 0.2 seconds
    ===================

    Please let me know whats the problem. Thanks.

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

Viewing 16 replies (of 16 total)
  • Plugin Author nosilver4u

    (@nosilver4u)

    For posterity:

    After more troubleshooting, it seems to have been a 2-part issue. The plugin was bailing out if images weren’t located within the wordpress folder, but it is possible on older blogs to have uploads that had absolute paths stored on an old part of the filesystem where WP used to be installed. To fix that, the plugin was modified to do a simple check that the file actually exists. Problem #1 solved.

    The second issue appeared to be that the web user did not have proper permissions on the old images, preventing them from being optimized. Unless webguru4u says otherwise, I believe changing permissions fixed the issue.

Viewing 16 replies (of 16 total)
  • The topic ‘Getting errors while optimizing’ is closed to new replies.