Support » Plugin: WooCommerce » Getting errors on status log after payment failed

  • Resolved rlwells1169

    (@rlwells1169)


    Hello, I am using WordPress 4.9.4 and Woocommerce 3.3.1. I am using Stripe integration and have the plugin for that as well, latest version.

    When I go to my checkout page, I attempt the process, it tells me “payment failed – please try again later”

    So I go to my Woocommerce > Status > Logs section and see the following 2 errors for today:

    2018-02-13T13:11:44+00:00 CRITICAL Call to a member function set_messages() on null

    2018-02-13T13:20:23+00:00 CRITICAL Call to undefined method WooCommerce::add_inline_js()

    I would investigate these functions but the log doesn’t say which file they are in. Would anyone from support be able to chime in? I can share login details if necessary, really want to get this resolved as soon as possible.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Zandy Ring

    (@zandyring)

    Automattic Happiness Engineer

    Hi rlwells1169,

    I’m sorry to hear about that! It sounds like there’s a plugin conflict happening. Could you try running some conflict testing?

    You’ll want to set up a staging site if you haven’t already. It takes just a few minutes to do. First, run a complete backup of your site, then install https://wordpress.org/plugins/wp-staging/ and set up a staging site.

    On your staging site, disable all your plugins except for WooCommerce and Stripe, and run the transaction again.

    If it STILL fails, try switching your theme to a standard theme, like Storefront or Twenty Seventeen.

    If it fails yet again, could you take this over to the Stripe forum (https://wordpress.org/support/plugin/woocommerce-gateway-stripe) because at that point it’ll most likely be an issue with Stripe, rather than WooCommerce itself.

    Let us know how the conflict testing goes!

    Cheers!

    Thread Starter rlwells1169

    (@rlwells1169)

    Thanks Zandy, I resolved this by backing up to the old version of Stripe payment gateway (3.2.3) there was a JS issue between the new version and theme.

    Thanks for getting back to me though! Have a wonderful day.

    Zandy Ring

    (@zandyring)

    Automattic Happiness Engineer

    I’m glad you found the cause! If you check with your theme author they may be willing to fix that up for you.

    I’m going to close this topic, but if you have any new issues, please do open a new one! 🙂

    Cheers

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Getting errors on status log after payment failed’ is closed to new replies.