Support » Plugin: Paid Memberships Pro - BuddyPress Add On » Getting Errors for setting page

  • Hi,
    I recently installed this addon for Membership & buddypress plugins. But I’m getting the following errors on my dev site and on a fresh wordpress.

    Warning: require_once(PMPRO_DIR/adminpages/admin_header.php): failed to open stream: No such file or directory in D:\xampp\htdocs\wp\wp-content\plugins\pmpro-buddypress\includes\pmpro-buddypress-settings.php on line 62

    Fatal error: require_once(): Failed opening required ‘PMPRO_DIR/adminpages/admin_header.php’ (include_path=’.;D:\xampp\php\PEAR’) in D:\xampp\htdocs\wp\wp-content\plugins\pmpro-buddypress\includes\pmpro-buddypress-settings.php on line 62

    Please suggest!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jason Coleman

    (@strangerstudios)

    I just pushed out v1.1 that may fix this issue. This is odd though because that looks like the kind of error that would be thrown if PMPro was not active (and so PMPRO_DIR is not set) but you were on the settings page. However, if PMPro is not active, you shouldn’t be able to get to the settings page.

    I’m also facing the same problem. I’ve installed the plugin today.

    alchemy512

    (@alchemy512)

    Hi,
    I am getting similar fatal errors on the Settings page of
    Paid Membership Pro Version 1.1.1

    Warning: require_once(PMPRO_DIR/adminpages/admin_header.php): failed to open stream: No such file or directory in /home6/buddybli/public_html/wp-content/plugins/pmpro-buddypress/includes/pmpro-buddypress-settings.php on line 62

    Fatal error: require_once(): Failed opening required
    PMPRO_DIR/adminpages/admin_header.php’ (include_path=’.:/opt/php70/lib/php’) in /home6/buddybli/public_html/wp-content/plugins/pmpro-buddypress/includes/pmpro-buddypress-settings.php on line 62

    Please advise.

    • This reply was modified 7 months ago by  alchemy512.
    alchemy512

    (@alchemy512)

    Solved!
    I see now what the problem was. The installation instruction state that one also have to have

    The plugin requires BuddyPress and Paid Memberships Pro to be installed and activated….

    After downloading & activating the bold-typed above, the errors are gone and I can now change the setting for pmpro-buddypress.
    I hope this helps somebody.

    • This reply was modified 7 months ago by  alchemy512.
    • This reply was modified 7 months ago by  alchemy512. Reason: added closing blockquote tag
    • This reply was modified 7 months ago by  alchemy512.
    dibyajitgoswamidg

    (@dibyajitgoswamidg)

    @alchemy512 Thanks, Man! This thing is really helpful. It works!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Getting Errors for setting page’ is closed to new replies.