WordPress.org

Support

Support » Plugins and Hacks » Contact Form 7 » Getting Error:Failed to send your message. Please try later or contact the admin

Getting Error:Failed to send your message. Please try later or contact the admin

Viewing 15 replies - 1 through 15 (of 18 total)
  • I need the answer to this questions also [mod: no bump – if you have exactly the same problem, please post details]

    I’m trying to send a simple contact form but with a drop down menu using the pipe | symbol to hide 35 different choices of email recipients.

    ERROR MESSAGE: Failed to send your message. Please try later or contact the administrator by another method.

    I am also using SMTP via gmail which seems to work fine for other operations, so I presume this is a CF7 fail…

    Forms is located here: http://loudouniwla.org/host/contact-us/

    Any helpful hints?

    Ditto. I followed these instructions to generate this form code:

    [select your-recipient "Please choose a department|info@example.org" "Ticketing|tickets@example.org" "Auditions|auditions@example.org" "Production staff inquiries|staff@example.org" "All other inquiries|info@example.org"]
    
    <p>Your Name (required)<br />
        [text* your-name] </p>
    
    <p>Your Email (required)<br />
        [email* your-email] </p>
    
    <p>Your Message<br />
        [textarea your-message] </p>
    
    <p>[submit "Send"]</p>

    I too get this error message.

    Fixed! In my case, I’d filled out the “To:” field in where the resulting message should be sent with [your recipient], when it should’ve been [your-recipient] (note the dash).

    However, I’m not receiving the emails being sent through the form…

    Hey Guys,

    1. The following problem may appear as below:

    a. As above, for kgagne certain fields might be filled in with wrong values.
    b. Certain fields might not be filled at all.
    c. The hosting is wrongly configured. (it’d require admin support)

    2. Steps to fix that:

    a. Make sure that you run the latest CF 7 version.
    b. Try running the default contact form without changing any markup – if it works, go back to 1. and configure your own form accordingly.
    – if it doesn’t work, then contact your hosting provider on what are the requirements CF7 is making usage of wp_mail function, which in exchange is making usage of php mail function. There are certain hosting providers for which this function might not work. After having the chat go back here.

    I’ve created a separate form that doesn’t use the piped select your-recipient function; instead, I defined a specific email address for the message to go to. That form is working fine. Still no luck on the one whose code I posted above, though.

    I’ve disabled Jetpack’s Feedback function, to eliminate any potential conflicts.

    -Ken

    OK, it’s working now — I think Jetpack was indeed a conflict, but there was another dumb configuration error on my part that wasn’t helping.

    Appreciate it. Oh, you are saying it’s working with ALL the recipients. That has been my struggle. To find a form that actually does what it boasts, Email multiple recipients. Only I have 35 I need to address. Of course this morning I am locked out of my DB, and in deep deep waters for me. But I appreciate the feedback. I’ll have to look into it again when I normalize.

    I am also having this issue. The form was working when I built it in ecshelp.com/test but when I moved it to ecshelp.com is stopped working.

    I noticed the form ID changed and I fixed that but it still isn’t working.

    Not sure, did I lose important information or data in the transfer?

    Everything else on the website seems to be working at the moment.

    Never mind. I uninstalled the plugin and re-installed it and that fixed the problem.

    Hi guys, having same issue. this is the code i have, but im not sure what went wrong with it.

    <p>Office to Contact*

    [select* office “Sydney | email.com.au” “Melbourne | email2.com.au”]</p>

    <p>Your Name*
    [text* your-name] </p>

    <p>Your Email*
    [email* your-email] </p>

    <p>Subject*
    [select* subject multiple “General” “Ticketing” “Sponsorship” “Others”]</p>

    <p>Your Message*
    [textarea* your-message] </p>

    <p>[submit “Submit”]</p>

    then in the mail, ive set the To: [office]

    ive tested the form with setting the To: field to my own email and that worked.

    Please help!

    I had this same problem and it stemmed from when I changed the password on the email in settings.

    I have updated to the latest version of Contact Form 7 and Word Press 3.6. I have four contact forms on my site – http://www.westminstertech.com. All were working before the updates, but now – none are.

    Any suggestions or help is GREATLY APPRECIATED!

    Thanks.

    Ted

    I uninstalled the plugin and re-installed it and that fixed the problem.

    i used email@mydomain.com and its stopped working. then i used gmail email id and now its working fine.

    Thanks
    Lovepreet

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Getting Error:Failed to send your message. Please try later or contact the admin’ is closed to new replies.
Skip to toolbar