Support » Plugin: Code Snippets » Getting error: Not sufficient permissions

  • Resolved biberkopf


    After updating a couple of WP-installations to version 3.5.1 from 3.4.1 I realise, that the Code Snippet plugin is not working. When clicking the “Manage”-link, I get this error:

    “You do not have sufficient permissions to access this page.”

    Also, I do not have a snippet-menu in the left hand side.

    I have tried to deactivate and reactivate the plugin, as well as manually overwriting the plugin folder via FTP. (I have not tried to delete the plugin from within WP, for fear of loosing some of my codes in the database.)

    To be honest I don’t remember if I have made any snippets at all in this installation, so I made a search in the wp_options database for “%snippet%” and found only a record with “code_snippets_version” and the value “1.4”. (I updated the plugin to 1.6.1 before I upgraded WordPress to 3.5.1.)

    How can I find and backup any old snippets in the database before I deinstall the plugin?

    Do you have any suggestion to how I might solve this problem?

    Thanks for an otherwise great plugin. And thank you in advance. 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Shea Bunge


    Query: can you access the import snippets page under the Tools > Import menu?

    I’d say that uninstalling and reinstalling the plugin is the best bet. You can backup the wp_snippets table in your database; that is where the snippets are stored. (The wp_ part will change depending on what your table prefix is set to.)

    Sorry, I didn’t notice the wp_snippets table. I only have one record in there. It was just a php script for testing image load errors from the development fase. Now that I know, I can safely reinstall. And I did and now I can get to the manage interface.

    Not sure if it has any bearings for you, but here’s a few other observation I did in the process.

    I did see a Code Snippets Import menu. I could see that an xml-file was needed for import. However, I did not find any export menu, until after I reinstalled, which lead me to believe the export process was parallel to the tools->import-process. Perhaps the import button really belongs with the export button in the manage GUI – for consistency?

    Thanx a lot for your fast response. Although I don’t use the plugin right now, I really think it’s a superb tool and I’ll use it as soon as I get a chance.

    Plugin Author Shea Bunge


    The export functionality is built-in to the Manage Snippets page. You select the snippets you wish to export and a file is generated. It works best this way as you need to choose what snippets should be exported. With importing, all you do is upload a file.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Getting error: Not sufficient permissions’ is closed to new replies.