Support » Fixing WordPress » Getting Error Message: Sorry, you are not allowed to access this page.

  • Resolved evelynf

    (@evelynf)


    Hi,
    This site started giving me this error last night after doing a few updates.
    juliaglyde.com

    When I try to access the admin page I’m getting that error.

    I have renamed the plugins folder, the mu-plugins folder,
    I’ve replace htaccess with a default, basic file.
    I’ve verified the database version number in the versions file matches the wp-options table.

    I tried renaming my themes to disable them, but a default theme did not start up. I’ve looked at the site in 3 different browsers to eliminate a cache issue.

    Help!!!
    Evelyn

Viewing 9 replies - 1 through 9 (of 9 total)
  • Oh, and I also updated the wp-admin and wp-includes folders with fresh wordpress files and also the core files in the root folder.

    Thanks,
    Evelyn

    Moderator t-p

    (@t-p)

    Please check the error logs on your server for a more specific error message and see why it’s failing. If you need help locating them, ask your hosting provider to help you with that.

    I’m working with the hosting support now and there don’t seem to be any error logs. We have tried pretty much every suggestion we find online but none of them work. We did find that if I go to wp-login.php it lets me login, but instead of showing the admin dashboard, it shows the home page.

    Thanks for your help!
    Evelyn

    One thing I noticed is that when I rename the theme and child theme I’m using, it doesn’t automatically install a default wordpress theme – there are 2 in the folder.. 2016 and 2017.
    Evelyn

    Moderator t-p

    (@t-p)

    Can you share url of the page that gives this error “Sorry, you are not allowed to access this page”?

    Hi,
    We solved it. Something happened to the wp-options database table. The field for user roles must have gotten corrupted as the administrator role wasn’t there. I thought I had added the notes here earlier. One of the more senior techs at godaddy suggested to check the user roles field and compare it with a website that worked. We copied the contents from that field and pasted it into the broken one and that immediately fixed it. We had noticed that if we went to juliaglyde.com/wp-login.php it let me login but I only could see the home page, no dashboard.

    I still don’t know what corrupted that particular field, I haven’t noticed any other problems.

    The symptoms were very strange for removing an administrator role – the site wouldn’t even display wp-admin page, but displayed that error message.

    I hope this helps someone else!
    Evelyn

    Moderator t-p

    (@t-p)

    Glad you got it sorted 🙂

    mckinleygriggs

    (@mckinleygriggs)

    I think I have this same exact problem could you provide a walk through on what you did? Thanks

    Moderator t-p

    (@t-p)

    @mckinleygriggs,

    This thread is not only close to 4 months old, but also marked “resolved”!!

    If the troubleshooting already posted made no difference for you, then, as per the Forum Welcome, please post your own topic.

    This thread is closed now.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Getting Error Message: Sorry, you are not allowed to access this page.’ is closed to new replies.