WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Getting Error in Importing WordPress XML File (10 posts)

  1. yogesh_gamer
    Member
    Posted 2 years ago #

    I am trying to upload my old wordpress XML file to my new website.
    XML file size is 8.01MB so I tried WXR File Splitter to split it into parts and then try to upload but I am getting this error:
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3374 bytes) in public_html/wp-content/plugins/wordpress-importer/parsers.php on line 143
    Please Help me

  2. Using FTP you can try increasing the memory for PHP and WordPress several different ways:

    1) You can edit the memory_limit line in your php.ini (if you have access to that file) to 64M:

    memory_limit = 64M;

    2) If you can't get to the php.ini file, add this line at the top of your .htaccess file:

    php_value memory_limit 64M

    3) If that doesn't work or throws a "500 Internal Server Error", delete the line from .htaccess.

    Then try adding the line below near the top of your wp-config.php file, right after the opening <?php

    define('WP_MEMORY_LIMIT', '64M');

    If none of those work, your host probably doesn't allow memory allocation overrides. You're stuck with what they give.

  3. yogesh_gamer
    Member
    Posted 2 years ago #

    When I tried 8.01MB file I got this error:
    Sorry, there has been an error.
    File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.

    When I am trying split files in two parts then i am getting this error:
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3374 bytes) in public_html/wp-content/plugins/wordpress-importer/parsers.php on line 143

    Is there any solution? Because its my one year hard work and I don't want to lose it.
    Please Please Help Me

  4. yogesh_gamer
    Member
    Posted 2 years ago #

    I split XML file into 2MB parts and uploaded the file. After upload I assign author name and now getting this error:

    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in public_html/wp-content/plugins/wordpress-importer/wordpress-importer.php on line 91

    Failed to import Media “Download-Your-World-Header.jpg”
    Failed to import Media “Download-Your-World-Header1.jpg”
    Failed to import Media “Download-Your-World-Header2.jpg”

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 8192 bytes) in public_html/wp-content/plugins/wordpress-importer/wordpress-importer.php on line 559

    I don't understand why I can't upload XML even in parts.
    Is that because of my old website which is expired?

  5. Did you try what I posted above about raising the memory allocation?

  6. yogesh_gamer
    Member
    Posted 2 years ago #

    Yes Sir. I tried. There is no php.ini file. I tried 3rd option but it didn't works for me.

  7. yogesh_gamer
    Member
    Posted 2 years ago #

    I split XML file into 0.1MB Parts. There are 87 Parts and except 14 parts I uploaded all.
    I am getting this error:
    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/yogeshga/public_html/wp-content/plugins/wordpress-importer/wordpress-importer.php on line 91
    Failed to import Media “PostName”

    All done. Have fun!
    Remember to update the passwords and roles of imported users.

    How to upload these 17 parts too?

  8. Cannot set time limit in safe mode....

    Ask you host to turn off safe mode.

  9. yogesh_gamer
    Member
    Posted 2 years ago #

    Well I skip other 17 parts. I think its enough for my new website.
    Thank u

  10. yogesh_gamer
    Member
    Posted 2 years ago #

    Heyy I just noticed that all post are imported. That error was because of images which I uploaded on my expired website.

Topic Closed

This topic has been closed to new replies.

About this Topic