Support » Plugin: Duplicator - WordPress Migration Plugin » Getting Error – Host Build Interrupt

  • Resolved Shrinivas

    (@shrinitech)


    Hey buddy,

    Hope you are doing great, I need some assistance from you, I am getting “Host Build Interrupt” error when I try to create a package in Duplicator plugin.

    It was all fine earlier, recently I updated my XAMPP (PHP Version: 7.4.4) and I am getting “Host Build Interrupt” error followed by this message – “This server cannot complete the build due to host setup constraints.”. The package creation process goes up 20% and ends up with the above error.

    I tried changing the PHP max_execution_time to 0 but no luck. The error comes up for all the localhost sites in XAMPP.

    Duplicator is one of my favorite plugins and a great tool to migrate the websites. Kindly help me to fix up the error.

    Here is the log file-

    ********************************************************************************
    DUPLICATOR-LITE PACKAGE-LOG: April 8, 2020 4:22 pm
    NOTICE: Do NOT post to public sites or forums 
    ********************************************************************************
    VERSION:	1.3.28
    WORDPRESS:	5.3.2
    PHP INFO:	7.4.4 | SAPI: apache2handler
    SERVER:		Apache/2.4.41 (Win64) OpenSSL/1.1.1c PHP/7.4.4 
    PHP TIME LIMIT: (0) no time limit imposed 
    PHP MAX MEMORY: 4294967296 (512M default) 
    MEMORY STACK: 8MB
    
    ********************************************************************************
    DATABASE:
    ********************************************************************************
    BUILD MODE:   MYSQLDUMP
    MYSQLTIMEOUT: 5000
    MYSQLDUMP:    Is Supported
    MYSQL DUMP ERROR 2
    
    ==================================================================================
    DUPLICATOR ERROR
    Please try again! If the error persists see the Duplicator 'Help' menu.
    ---------------------------------------------------------------------------------
    MESSAGE:
    	Shell mysql dump error
    DETAILS:
    	change Mysql dump engine in PHP mode
    TRACE:
    	 1. class.pack.database.php : Error (545)
    	 2. class.pack.database.php : mysqlDump (187)
    	 3. class.pack.php : build (1233)
    	 4. ctrl.package.php : runZipBuild (97)
    	 5. class-wp-hook.php : duplicator_package_build (288)
    	 6. class-wp-hook.php : apply_filters (312)
    	 7. plugin.php : do_action (478)
    	 8. admin-ajax.php : do_action (175)
    ==================================================================================
    
    ==================================================================================
    DUPLICATOR ERROR
    Please try again! If the error persists see the Duplicator 'Help' menu.
    ---------------------------------------------------------------------------------
    MESSAGE:
    	Runtime error in DUP_Database::Build
    DETAILS:
    	Exception: Exception: DUPLICATOR ERROR: Please see the 'Package Log' file link below. in C:\xampp\htdocs\mysite\wp-content\plugins\duplicator\classes\class.logging.php:275
    Stack trace:
    #0 C:\xampp\htdocs\mysite\wp-content\plugins\duplicator\classes\package\class.pack.database.php(545): DUP_Log::Error('Shell mysql dum...', 'change Mysql du...', 1)
    #1 C:\xampp\htdocs\mysite\wp-content\plugins\duplicator\classes\package\class.pack.database.php(187): DUP_Database->mysqlDump('C:/xampp/mysql/...')
    #2 C:\xampp\htdocs\mysite\wp-content\plugins\duplicator\classes\package\class.pack.php(1233): DUP_Database->build(Object(DUP_Package), 1)
    #3 C:\xampp\htdocs\mysite\wp-content\plugins\duplicator\ctrls\ctrl.package.php(97): DUP_Package->runZipBuild()
    #4 C:\xampp\htdocs\mysite\wp-includes\class-wp-hook.php(288): duplicator_package_build('')
    #5 C:\xampp\htdocs\mysite\wp-includes\class-wp-hook.php(312): WP_Hook->apply_filters('', Array)
    #6 C:\xampp\htdocs\mysite\wp-includes\plugin.php(478): WP_Hook->do_action(Array)
    #7 C:\xampp\htdocs\mysite\wp-admin\admin-ajax.php(175): do_action('wp_ajax_duplica...')
    #8 {main}
    TRACE:
    	 1. class.pack.database.php : Error (222)
    	 2. class.pack.php : build (1233)
    	 3. ctrl.package.php : runZipBuild (97)
    	 4. class-wp-hook.php : duplicator_package_build (288)
    	 5. class-wp-hook.php : apply_filters (312)
    	 6. plugin.php : do_action (478)
    	 7. admin-ajax.php : do_action (175)
    ==================================================================================
Viewing 5 replies - 1 through 5 (of 5 total)
  • I am having similar issues. I have been trying to only do a database backup and it fails after a few seconds. If I switch away from mysqldump in the settings, it works.

    I’m running on a homebrew localhost setup on a MacBook Pro with all the limits removed as far as time goes. Very odd behavior, I think. Hopefully there’s something here that gives you an ah-ha moment and it’s a simple setting?

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @fotan @shrinitech

    Thanks for the feedback! There are a few items in the FAQ that may provide a solution to this issue, this one may get you going.

        – What can I do for issues with migrating a large site on a limited host?
        – https://snapcreek.com/duplicator/docs/faqs-tech/#faq-package-015-q

    Let me know if this helps~

    @fotan thank you for your suggestion, switching the SQL Script option from Mysqldump to PHP code helped.

    @corylamleorg Thank you for the quick response.

    So Mysqldump setting is causing the issue with the latest XAMPP (PHP version 7.4.4).

    To add a note – I also got some PHP warnings on my localhost sites from some other plugins as well. Does it mean the Duplicator plugin needs to be updated to support PHP version 7.4.4?

    Thanks again for the awesome plugin.
    Have a great day guys!

    Hey @corylamleorg Thanks for getting back. At least in my case those links won’t help. I already went through them before posting here.

    When I run a backup on just the DB it fails at seemingly random times. Usually in the 2-5 second range. I’m using the latest PHP 7.3.x on my laptop dev environment but tried 7.2.x and 7.4.x as well.

    At least in my case there definitely seems to be a problem with mysqldump. I have uninstalled MariaDB and reinstalled it. My dev environment was set up using Homebrew and everything is up to date. I also ran brew doctor and fixed everything that showed there.

    Any other ideas? It’s driving me nuts.

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @fotan

    If you want to submit a support ticket for this issue we can have a closer look at your setup/logs. Please provide a link to this thread when submitting the ticket.

    Thanks~

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Getting Error – Host Build Interrupt’ is closed to new replies.