Support » Plugin: WP-Optimize - Clean, Compress, Cache. » Getting ‘error’ after activating Gzip compression

  • Resolved Jack

    (@moxie)


    I got this message after activating Gzip Compression:

    We successfully added Gzip compression settings into .htaccess file. But it seems one of Apache modules – mod_filter or mod_deflate is not active.

    But GTMetrix says Gzip is fine. I asked my provider and they do not have those modules installed/activated.

    I have used several caching plugins, and for the last few years WP Super Cache. This is the first time I got such a message.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author David Anderson

    (@davidanderson)

    Hi Jack,

    Please can you let us know your site URL? Then we can take a look. We don’t need any special access, just the public website address.

    David

    Hi David. I just got a reply from my hosting agency and they offered me some code I could add to htaccess to get gzip working, and one line of code at the top of wp-config. I suppose that works as well. But activating Gzip within the plugin did not work. Some code is indeed added to htaccess, but within the settings Gzip remains deactivated.

    Anyhow, here is the url: https://www.jacktummers.nl/

    Let me know if you need anything else.

    This is the code I used from the provider. The information around the code is in Dutch, but not the code ;).
    https://www.transip.nl/knowledgebase/artikel/366-gzip-gebruiken-in-wordpress/

    Plugin Author David Anderson

    (@davidanderson)

    Hmmm, the details are a bit puzzling. You say, referring to mod_filter and mod_deflate:

    I asked my provider and they do not have those modules installed/activated.

    However, the snippet at https://www.transip.nl/knowledgebase/artikel/366-gzip-gebruiken-in-wordpress/ uses mod_deflate and mod_filter. So those two pieces of information are inconsistent. Please could you clarify with your hosting provider? It doesn’t make sense for them to suggest using code that relies on two modules that they say aren’t available.

    It seems that those modules are available but in order to use it I had to be very specific in what to place inside the htaccess file, hence the code they provide. So I guess I will use your caching system and let gzip be handled by that code.

    Plugin Author David Anderson

    (@davidanderson)

    Hi,

    We’re looking into this. We have one other user with a related report. We are trying to make sure we get the logic exactly right rather than just releasing something that will patch it up for you two, as things can get quite complex.

    David

    Plugin Author David Anderson

    (@davidanderson)

    Hi,

    Please try again with the just-released WP-O 3.0.7 – this should fix it.

    David

    Hi David. Thanks for the new version!

    I updated the plugin and removed the code I got from the provider, but I’m still receiving the same message:

    http://pix.toile-libre.org/upload/original/1564127075.jpg

    Hello,

    I have the same issue.

    Plugin Author David Anderson

    (@davidanderson)

    Hi Jack,

    Ah, sorry – I confused this topic with another. There weren’t any changes in 3.0.7 related to this.

    Looking at the code, the message shown does not necessarily match the true cause. I’ve adjusted this for our next release. Possible causes can include that Apache (if in use) is not configured to allow .htaccess files to take effect, or one of Apache modules – mod_filter or mod_deflate – is not active, or that Apache is configured to disallow Gzip compression regardless of what’s configured in an .htaccess file.

    The message also fails to clarify that its presence definitely indicates that Gzip compression is not active on static resources.

    In your case, I can see that you are using Cloudflare for your website. Cloudflare say that they automatically apply Gzip compression even if the origin didn’t, unless you’ve specifically turned it off – https://support.cloudflare.com/hc/en-us/articles/200168396-What-will-Cloudflare-compress- . So, check your Cloudflare settings – and if it’s not turned off there, you should ask Cloudflare support; in this case, it’s under their control.

    Thanks David for taking the time to figure this out! I have checked Cloudflare and Gzip (Brotli) is enabled, so that’s fine. I will leave gzip turned off and just use the caching system.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.