WordPress.org

Support

Support » How-To and Troubleshooting » Getting "Cheating Huh?" error since 3.4 upgrade

Getting "Cheating Huh?" error since 3.4 upgrade

Viewing 15 replies - 1 through 15 (of 29 total)
  • That would be something to ask on the headway forums, I’m afraid.

    I did that, but this happened after the 3.4 WP upgrade, and I see other folks are having problems here, too.

    yes! I’m experiencing it since the upgrade too!

    Its a wordpress upgrade issue. Definitely not a theme issue. I see alot of people having the same problem. Everything was working great before.

    Top administrator has no issue but all my authors are experiencing problems when trying to add a “feature image” to their posts

    I’m getting the same thing. Its not even a shared blog. Installed a new theme and get the error. I even tried erasing wordpress and the database and starting over, I still have the same error. Happening when I try to upload an image in the themes custom panel.

    Just keeps saying “Cheating Huh?”

    No WordPress I’m not cheating. I don’t even look when another more attractive content management systems walk by….

    LOL. Nikkeya, that last part is cute. Heehee!

    @nikkeya lmfao! I dont either!! haha!!! Oh, thanks for the good laugh!

    LOL, Glad to give everyone a smile today!

    I downgraded back to 3.3.2 and problem solved, but I know it can’t stay that way because of the security updates. This is super weird. I see a lot of people searching for it but the only thing I’m seeing is something about capital letter in codes, but it doesn’t seem to apply here.

    Hello,
    Did anyone solve this issue in an other way then downgrading?
    If so please do share!!

    I downgraded back to 3.3.2 and problem solved, but I know it can’t stay that way because of the security updates.

    Great! Now there is one more step. Reinstall 3.4.1. Sure, no damsel will tell you, “Cheatin Uh?”

    Not a joke! Try it!

    I did your recommendation and re-installed my new wordpress again dear Krishna but it doesn’t work!! still receive this damn massage during uploading the images!!

    and let me notice that I am trying to customize my ELEGANT THEME inside its Epanel!!

    I am having a similar issue since upgrading to 3.4.1….When I go to my themes page in the admin panel, none of the images will show…just the blue box with the X in it.

    Checked all of the permissions and they are good.

    Same issue here. Can’t seem to upload any images to my gallery. HAS to be 3.4.1. Everything was just fine before the upgrade.

    Same issue here as well. Would be nice if there was a fix for this.

    Found a fix via a post by a member named wasjunior who referenced Thaideas‘s original post method.

    1. Login to your plesk/cpanel, whatever you use. Locate
    wp-admin/media-upload.php

    Open the media-upload.php with the code editor scroll down to line #125 and change the code

    if ( ! empty( $_REQUEST[‘post_id’] ) && ! current_user_can( ‘edit_post’ , $_REQUEST[‘post_id’] ) )

    to

    if ( ! empty( $_REQUEST[‘post_id’] ) && current_user_can( ‘edit_post’ , $_REQUEST[‘post_id’] ) )

    Make sure you don’t touch line 126 with a code that looks like this wp_die( __( ‘Cheatin’ uh?’ ) );—– DON’T TOUCH THIS
    Save and get back to your wordpress admin panel, make sure you have cleared your cache and this should do it.

    By removing the “!” you should be able to upload your images.
    Keeping the “!” allowed for me to upload a “feature images” on my theme. It’s a pain to switch back and forth but it’s the only fix I’ve found so far.

    Now I’m having problems uploading my title images… will these issues ever cease? UGH…

    PLEASE let me know if you have any other fixes.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Getting "Cheating Huh?" error since 3.4 upgrade’ is closed to new replies.