WordPress.org

Forums

[resolved] Getting Blank Page but Logging in It Looks Fine (28 posts)

  1. jimfelder
    Member
    Posted 2 years ago #

    Our site http://www.ppok.org is getting a blank page. When I log in it looks ok. If I go to the site on my iPhone it works fine even when not logged in.

    I have tried with all plugins turned off also.

    I've searched the forums, I've replaced my htaccess file. I'm not that great with the back end code but if I dig and research I sometimes can figure it out. At this point I need help because I need the members to be able to get to the site, especially during this time.

    Thank You.

  2. jimfelder
    Member
    Posted 2 years ago #

    Just tried to reinstall WordPress. Still not working.

  3. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Have you tried deactivating ALL plugins and switching to the default twentytwelve theme?

  4. jimfelder
    Member
    Posted 2 years ago #

    Yes, I've done that.

  5. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Try resetting the plugins folder - change the name on the plugins folder to "pluginsHOLD" temporarily and switch to the default theme with them deactivated that way.

    I see the site on mobile - what theme is that? Do you have a separate mobile site or are you using a mobile version/switcher?

  6. jimfelder
    Member
    Posted 2 years ago #

    I turned on Blackbox to see the errors but not sure what to do with any of these:

    Notice Undefined index: onehalf_margin_type on line 114 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-content/plugins/easy-columns/easy-columns.php
    Notice Undefined index: threequarter_margin_type on line 118 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-content/plugins/easy-columns/easy-columns.php
    Strict Redefining already defined constructor for class nggdb on line 60 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-content/plugins/nextgen-gallery/lib/ngg-db.php
    Strict Redefining already defined constructor for class nggPostThumbnail on line 26 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-content/plugins/nextgen-gallery/lib/post-thumbnail.php
    Strict Redefining already defined constructor for class nggNavigation on line 50 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-content/plugins/nextgen-gallery/lib/navigation.php
    Strict (7) is_a(): Deprecated. Please use the instanceof operator on line 486 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-includes/capabilities.php
    Strict (5) Only variables should be assigned by reference on line 57 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-content/plugins/events-planner-pro-1.3.11.5/system/epl-base.php
    Strict Only variables should be passed by reference on line 210 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-includes/pomo/mo.php
    Strict (228) is_a(): Deprecated. Please use the instanceof operator on line 390 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-includes/post.php
    Strict Only variables should be assigned by reference on line 9 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-content/plugins/events-planner-pro-1.3.11.5/application/libraries/epl-advanced-cal-widget.php
    Strict Only variables should be assigned by reference on line 9 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-content/plugins/events-planner-pro-1.3.11.5/application/libraries/epl-upcoming-events-widget.php
    Strict (20) is_a(): Deprecated. Please use the instanceof operator on line 127 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-includes/functions.wp-scripts.php
    Strict (12) is_a(): Deprecated. Please use the instanceof operator on line 135 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-includes/functions.wp-styles.php
    Strict (3) is_a(): Deprecated. Please use the instanceof operator on line 54 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-includes/functions.wp-scripts.php
    Strict is_a(): Deprecated. Please use the instanceof operator on line 83 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-includes/functions.wp-styles.php
    Strict (3) Only variables should be assigned by reference on line 20 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-content/plugins/events-planner-pro-1.3.11.5/system/epl-model.php
    Strict (2) is_a(): Deprecated. Please use the instanceof operator on line 821 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-content/themes/Basic/epanel/custom_functions.php
    Strict (4) is_a(): Deprecated. Please use the instanceof operator on line 207 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-includes/class-wp-error.php
    Strict (2) is_a(): Deprecated. Please use the instanceof operator on line 88 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-includes/functions.wp-scripts.php
    Strict is_a(): Deprecated. Please use the instanceof operator on line 265 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-includes/class-wp-theme.php
    Strict is_a(): Deprecated. Please use the instanceof operator on line 28 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-includes/functions.wp-styles.php
    Strict is_a(): Deprecated. Please use the instanceof operator on line 727 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-includes/script-loader.php
    Strict is_a(): Deprecated. Please use the instanceof operator on line 646 in file /home/vg004web01/36/60/3006036/web/wordpress/wp-includes/script-loader.php

  7. jimfelder
    Member
    Posted 2 years ago #

    THAT WORKED! Now what if I change the folder back? Why would this happen?

  8. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Looks like you have some plugin conflicts or problems between the theme and plugin(s) or plugins can conflict with each other. Is that with your theme or twentytwelve? Are all of them current and compatible with WP3.5.1?

    The usual way to identify problematic things like this is to reactivate your theme and then the plugins one by one - to see if and when the problem reoccurs.

  9. jimfelder
    Member
    Posted 2 years ago #

    it worked with our theme. I'll turn on my newest plugin that I've added in the last few days.

  10. jimfelder
    Member
    Posted 2 years ago #

    OK, each time I change back to my theme it craps. I have to change the plugins folder to OLD and to twentyeleven and it comes back.

    No matter what plugin I activate, it craps.

  11. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Then you have a theme problem - what theme are you using?

  12. jimfelder
    Member
    Posted 2 years ago #

    Basic from Elegant Themes. I have downloaded the updated theme. I had a child theme.

    I deleted the original and the child, now I'm copying the new theme folder. I'll activate that first. If that works then I'll create a child from that.

  13. jimfelder
    Member
    Posted 2 years ago #

    Actually, I left the twentytwelve theme active, activated one plugin and it crapped. renamed the plugins folder and it's back. Must be something in the plugins folder?

  14. jimfelder
    Member
    Posted 2 years ago #

    I just renamed it again back to plugins and not change the theme it's crapped again.

  15. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Could be - you could try reinstalling the plugins. Do be sure you've backed up your site :)!

  16. jimfelder
    Member
    Posted 2 years ago #

    just changed the plugins folder to pluginsOLD and the site is up with twenty twelve. weird

  17. WPyogi
    Forum Moderator
    Posted 2 years ago #

    You could also first try reinstalling WP - manually by downloading a new copy of WP to your local computer and then first deleting all files/folders EXCEPT wp-content - and then replacing those from the new download - again, don't overwrite wp-content.

  18. jimfelder
    Member
    Posted 2 years ago #

    what if I create a new plugins folder and install the plugins?

  19. WPyogi
    Forum Moderator
    Posted 2 years ago #

    You can certainly try that... You do have it backed up, right?

  20. jimfelder
    Member
    Posted 2 years ago #

    yes, I copied the basic theme and child theme to my computer and I backup the database with a plugin Better WordPress Security.

  21. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Okay, cool...just making sure. Sorry to be a bit overbearing on that, I just really hate bad endings like "OMG, that just deleted my whole site - no one told me to backup!"

  22. jimfelder
    Member
    Posted 2 years ago #

    OK, added and activated updated theme. created child theme. now to try activating NEEDED plugins.

  23. jimfelder
    Member
    Posted 2 years ago #

    would you be willing to help me figure out where to change the code to move my logo up and left?

    I had this in the Basic Theme and didn't know how to change it in the child theme. I don't remember where I changed this. If you can't I understand.

    Thanks so much for the help.

  24. jimfelder
    Member
    Posted 2 years ago #

    Crazy thing is that when I'm logged in the logo is in the right spot but on my macbook it's wrong.

  25. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Sure, see if this CSS works:

    .logo {
        border: 0 none;
        float: left;
        margin: 5px 0 0 30px;
    }
  26. jimfelder
    Member
    Posted 2 years ago #

    I found a fix on the theme's site before you posted. Thanks anyway.

    Hey if I could send you a batch of cookies or candy or something I would. YOU ROCK! Thanks dude.

  27. WPyogi
    Forum Moderator
    Posted 2 years ago #

    LOL - virtual cookies are lovely :)! (And BTW, it's dudette...)

  28. jimfelder
    Member
    Posted 2 years ago #

    LOL CRAP! OK Dudette! YOU STILL ROCK!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags