Support » Plugin: TablePress » Getting blank error when saving “Saving failed: AJAX call failed: error – .”

  • Resolved Zach Wills

    (@oxymoron)



    On one of our websites we have the following reported issue:

    > It only happens when I’m working in the TablePress plugin entering data for the menus. Usually, I work on the data entry for 3 – 4 hours and I save it every 30 minutes or so and do that for a few days until I finish the menus. Eventually, it’ll give me the call error message and tell me to hold shift while I save, which I tried, and it’ll erase data that I had saved – up through the whole session sometimes. But if I don’t push shift, it won’t save anything, so I usually just back out now when I see the message. But obviously, I still end up losing 30 minutes of work or so every time I do this. So I don’t know if that’ll be super easy to replicate.

    I tried replicating and wasn’t able to. After talking with the client further, it seems that the issue occurs the longer they are working on a table. I looked through the existing support threads, but it seems each of the other incidents involving this AJAX error includes an additional message like ‘Internal Server Error’ or ‘Not found’. Unfortunately, in our case, it just says Saving failed: AJAX call failed: error - ..

    It’s difficult to replicate since it seemingly occurs only after working on an existing table for a long time. Have you had any other reports of something like this happening? Is there a reason the error message is blank?

    Regards,

    Zach

Viewing 1 replies (of 1 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble.

    It’s indeed weird that there’s no extra information in the error message, like “Not found” or “Internal Server Error”. This could mean that your server returns something uncommon.
    The long wait between the saving should not be an issue here. My guess would rather be that the size of the table throws off the server (or some software on the server) at one point, e.g. due to memory limits.

    Can you consistently reproduce this behavior on a table, e.g. by adding more rows with arbitrary content? If so, I could maybe try to directly debug this.

    Regards,
    Tobias

Viewing 1 replies (of 1 total)
  • The topic ‘Getting blank error when saving “Saving failed: AJAX call failed: error – .”’ is closed to new replies.