Support » Plugin: Jetpack by WordPress.com » Getting an image to appear when linking to Facebook

  • Resolved gavinh

    (@gavinh)


    Hello,

    I have been able to activate the Facebook button on my posts. However, when I click on it and the Facebook “Share This Link” popup comes, there is no image attached to the post. How can I get an image to appear to go along with the text?

    http://wordpress.org/extend/plugins/jetpack/

Viewing 5 replies - 1 through 5 (of 5 total)
  • gavinh

    (@gavinh)

    Nevermind. The thing seems to have fixed itself. WEEEEIRD!!!!

    Plugin Author Jeremy Herve

    (@jeherve)

    I’m glad to hear you’re all set.

    The problem was probably linked to Facebook’s cache. Facebook caches information about each one of your blog posts, and sometimes fails to cache the correct title, description, or image for your post. When that happens, you can clear Facebook’s cache for that post by entering its URL into the debugger here:
    https://developers.facebook.com/tools/debug

    gavinh

    (@gavinh)

    it’s not working again. any thoughts on this inconsistency?
    also, i put the url http://weshareinterests.com/?p=6 into the debug site. i don’t see anything to clear cache. just this. thoughts?

    Scrape Information

    Response Code:

    206

    Fetched URL:

    http://weshareinterests.com/?p=6

    Canonical URL:

    http://weshareinterests.com/?p=6

    Errors That Must Be Fixed

    Cannot change og_type:

    The object at ‘http://weshareinterests.com/?p=6’ previously had type ‘article’ and cannot be changed to an object of type ‘website’ to avoid data corruption of existing actions.

    ——————————————————————————–

    URLs

    Graph API:

    http://graph.facebook.com/120081664838422

    Scraped URL:

    See exactly what our scraper sees for your URL

    gavinh

    (@gavinh)

    and now it’s working. again…maybe i/other users just have to keep trying until they get the image. that’s pretty annoying, actually. if there is a way to solve this, it’d be great to find out what it is.

    Plugin Author Jeremy Herve

    (@jeherve)

    it’s not working again. any thoughts on this inconsistency?
    also, i put the url http://weshareinterests.com/?p=6 into the debug site. i don’t see anything to clear cache. just this. thoughts?

    When submitting the URL to the debugger, Facebook’s cache is cleared.

    If you keep experiencing issues, you can report it to the Facebook developers here:
    https://developers.facebook.com/bugs/

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Getting an image to appear when linking to Facebook’ is closed to new replies.