Support » Plugin: Broadcast » Getting an error when trying to broadcast

  • So I am getting this error when trying to Broadcast an ACF Options page. Premium Pack is registered and up to date.

    PHP message: PHP Fatal error:  Uncaught Exception: Serialization of 'Closure' is not allowed in /www/wp-content/plugins/threewp-broadcast-premium-pack/src/queue/data.php:42
    Stack trace:
    #0 /www/wp-content/plugins/threewp-broadcast-premium-pack/src/queue/data.php(42): serialize(Object(threewp_broadcast\broadcasting_data))
    #1 /www/wp-content/plugins/threewp-broadcast-premium-pack/src/queue/Post_Queue.php(231): threewp_broadcast\premium_pack\queue\data->compress(Object(threewp_broadcast\broadcasting_data))
    #2 /www/wp-includes/class-wp-hook.php(287): threewp_broadcast\premium_pack\queue\Post_Queue->threewp_broadcast_broadcast_post(Object(threewp_broadcast\broadcasting_data))
    #3 /www/wp-includes/plugin.php(206): WP_Hook->apply_filters(Object(threewp_broadcast\broadcasting_data), Array)
    #4 [internal function]: apply_filters('threewp_broadca...', Object(threewp_broadcast\broadcasting_data))
    #5 /www/wp-content/plugins/threewp-broadcast/src/sdk/wordpress/actions_and_filters_trait.php(131): call_user_func_array('ap

    When I check the code in data.php, line 42 is this:

    $new_data = serialize( $data );

    And that is part of this function:

    	/**
    		@brief		Convenience method to serialize, compress and store the data.
    		@since		2017-10-11 11:59:05
    	**/
    	public function compress( $data )
    	{
    		$new_data = serialize( $data );
    		$new_data = gzcompress( $new_data , 9 );
    		$new_data = base64_encode( $new_data );
    		return $this->set_data( $new_data );
    	}

    Can you advise on what I need to do to make this error go away?

    • This topic was modified 3 months, 1 week ago by arufasari.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author edward_plainview

    (@edward_plainview)

    Oh my! I didn’t get the e-mail notification for this question.

    I’m thinking that you have a plugin that is preventing Broadcast from saving its data.

    The solution is to selectively disable your active plugins, one by one, until the problem goes away. After that we can figure out how to work around that plugin’s saving data.

    Thank you for the reply, Edward!

    So I did disable all plugins on the multisite one by one. I got to Divi, ACF Pro, ACF Options Admin, ThreeWP Broadcast and ThreeWP Broadcast Premium Pack. It is still erroring out.

    PHP Warning: Invalid argument supplied for foreach() in /www/wp-content/plugins/threewp-broadcast-premium-pack/src/acf/ACF.php on line 1479

    That is what I get when I go to “Broadcast Options Pages” which is essential to the broadcast that’s failing, as the Page has Options Pages attached to it using ACF. I also see this error in the error log.

    I should mention I verified all user roles are the same on the site being broadcasted from and the site being broadcasted to. I turned on ThreeWP Broadcast Debugging, but got little in the way of information there.

    • This reply was modified 2 months, 3 weeks ago by arufasari.
    • This reply was modified 2 months, 3 weeks ago by arufasari.

    Okay. So I am able to Broadcast the Options pages and actual Page that I need if I do it this way:

    Go to Template site (broadcasting from)
    Go to Broadcast > ACF and broadcast options pages to selected blog
    Go to Plugins in Network and disable Premium Pack across the Multisite network
    Go back to Template site, and go to Pages then Broadcast page to the selected blog

    So this will work if I do it this way, but not with Premium Pack enabled when I go to do it from the actual Page editor interface.

    Hey Edward, did you have any ideas for me on this? I did use the Health Check plugin made by the WordPress team, it says this plugin is made for PHP 5.6- but it works sometimes for us. Should our PHP version be set to 5.6 to use your plugins?

    Edward, I have another update:

    I tried disabling all the plugins except Broadcast, User Role Editor and Broadcast Premium pack. When I tried to do a User Role Sync via Broadcast Premium Pack, it goes through, but the user roles do not show up or sync to the site I broadcast to. What else can I do to fix this problem or diagnose what could be happening? This was working about a month ago, and when we went to try it today it doesn’t go through.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.