Support » Plugin: Elementor Custom Skin » Getting admin-ajax 500 error while using LOAD MORE button in only one site.

  • jtas

    (@jtas)


    The plugin works fine in all other sites where I am using it. But in one site hosted in DigitalOcean droplet – the Loadmore button is not working. It is stuck and showing Loading…, in console I am getting ajax-admin error 500.

    Here’s the wp-debug log –

    [01-May-2021 06:12:01 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function mb_convert_encoding() in /var/www/html/wp-content/plugins/ele-custom-skin/includes/ajax-pagination.php:445
    Stack trace:
    #0 /var/www/html/wp-content/plugins/ele-custom-skin/includes/ajax-pagination.php(433): ECS_Ajax_Load->clean_response()
    #1 /var/www/html/wp-includes/class-wp-hook.php(287): ECS_Ajax_Load->get_document_data()
    #2 /var/www/html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters()
    #3 /var/www/html/wp-includes/plugin.php(484): WP_Hook->do_action()
    #4 /var/www/html/wp-admin/admin-ajax.php(184): do_action()
    #5 {main}
      thrown in /var/www/html/wp-content/plugins/ele-custom-skin/includes/ajax-pagination.php on line 445

    Can you please help on how to solve this?

Viewing 1 replies (of 1 total)
  • Thread Starter jtas

    (@jtas)

    sudo apt-get install php7.4-xml
    sudo apt-get install php7.4-mbstring

    This did the work. Sharing as someone could benefit form this.

    Edit:
    Now only getting a Notice in log

    [01-May-2021 07:00:26 UTC] PHP Notice: Undefined variable: query_vars in /var/www/html/wp-content/plugins/ele-custom-skin/includes/ajax-pagination.php on line 436

    • This reply was modified 7 months ago by jtas.
Viewing 1 replies (of 1 total)
  • The topic ‘Getting admin-ajax 500 error while using LOAD MORE button in only one site.’ is closed to new replies.