Support » Plugin: Social Share Icons & Social Share Buttons » Getting a Warning when updating

  • Resolved makphisto

    (@makphisto)



    When I attempt to update the plugin, my site gets several warnings. I’ve rolled back so the warnings aren’t showing, but this is what it is:

    Warning: Declaration of truethemes_sub_nav_walker::start_lvl(&$output, $depth) should be compatible with Walker_Nav_Menu::start_lvl(&$output, $depth = 0, $args = Array) in /home/silcofil/public_html/wp-content/themes/sterling/framework/theme-specific/navigation.php on line 0

    Warning: Declaration of truethemes_sub_nav_walker::end_lvl(&$output, $depth) should be compatible with Walker_Nav_Menu::end_lvl(&$output, $depth = 0, $args = Array) in /home/silcofil/public_html/wp-content/themes/sterling/framework/theme-specific/navigation.php on line 0

    Warning: Declaration of truethemes_sub_nav_walker::start_el(&$output, $item, $depth, $args) should be compatible with Walker_Nav_Menu::start_el(&$output, $item, $depth = 0, $args = Array, $id = 0) in /home/silcofil/public_html/wp-content/themes/sterling/framework/theme-specific/navigation.php on line 0

    Warning: Declaration of truethemes_sub_nav_walker::end_el(&$output, $item, $depth) should be compatible with Walker_Nav_Menu::end_el(&$output, $item, $depth = 0, $args = Array) in /home/silcofil/public_html/wp-content/themes/sterling/framework/theme-specific/navigation.php on line 0

    Warning: Declaration of truethemes_gallery_walker::start_el(&$output, $category, $depth, $args) should be compatible with Walker_Category::start_el(&$output, $category, $depth = 0, $args = Array, $id = 0) in /home/silcofil/public_html/wp-content/themes/sterling/framework/theme-specific/navigation.php on line 0

    I did reach out to the theme dev and he agreed that it’s a plugin issue. I’ve tried every possible combo – setting the theme to 2017 and then updating the plugin and deleting the plugin then resetting to Sterling them breaks the site. All I want to do at this point is remove the plugin totally so it doesn’t break the site.

    Any thoughts?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author socialdude

    (@socialdude)

    Thanks for reaching out!

    The quick fix for this: On the plugin’s settings page there is an option to switch this “Error reporting” off (at the bottom of question 6). Could you please try that?

    It’s safe to switch those errors off because they usually don’t point to a serious issue. However, if you still want to get to the bottom of this, then please ask your theme developers to have a second look… as it’s related to the theme. We can also debug those things as part of this plugin https://www.ultimatelysocial.com/usm-premium/

    Thanks for the quick reply – I don’t see any options for Error Reporting on Question 6 (or any others). I might just be missing it, but can you confirm it’s location/wording?

    Plugin Author socialdude

    (@socialdude)

    Reason might be that you switched back to old version where we didn’t have it yet – on which version are you on right now?

    Plugin Author socialdude

    (@socialdude)

    It should be at bottom of question 6, see https://www.screencast.com/t/d2jwhGfl

    Ah yes. I was at 2.8.9. Updating to 2.9.0 did give me the option to suppress error reporting – but unfortunately I still get the warnings at the top. Any creative way to simply remove all traces of the plugin entirely?

    Plugin Author socialdude

    (@socialdude)

    With error messaging off you shouldn’t get those. Could you please clear cache? By that, I mean…

    The browser cache, see https://www.solutionbay.com/solutions/dont-know-how-to-clear-the-cache-1
    Please also check if you have a cache plugin installed. If so, please disable it temporarily, and check if it’s ok now

    Are they gone then?

    Yep, that seems to have done it. Thank you! Marking solved.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.