Support » Plugin: Five Star Restaurant Reservations » Getting a reservation form to only use 1 location

  • Resolved beanthere22

    (@beanthere22)


    I tried modifying the shortcode with location=123 (yes I used my location number), but the form still came up with a dropdown menu for locations.

    I would like to just have the form relate to one location, then another form on another page relating to the second location.

    No dropdown location menu.

    Is that possible. Been using this for a while with a single location and they are very happy with it, but expanding to another location.

    Thanks,

    Sam

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi Sam,

    The location attribute should work. Here’s a few things to check:

    1. Is the ID you’re using the correct ID for your location? This should be the ID of the location created using the Business Profile plugin.

    2. Does it work if you deactivate all other plugins and switch to a default theme (like TwentySeventeen)?

    Do you mean this?
    https://www.dropbox.com/s/g1i2cht26wcj4jj/location%20Capture.PNG?dl=0

    When I use [booking-form location=4559] this is what I get:
    https://www.dropbox.com/s/tje0shdekufb6z2/location%20Capture2.PNG?dl=0

    I am using the Jupiter theme which uses Visual Composer. The form is in a VC text block container. I have tried it in several browsers and on my phone, same result.

    When I put the [booking-form location=4559] into a regular WordPress page (Still in Jupiter, not using VC), I get this form:
    https://www.dropbox.com/s/6pbf1bzgw8j6ft5/location%20Capture4.PNG?dl=0
    and the location is no longer in a dropdown.

    When I fill out the form on the standard WordPress page, then go to the bookings menu to review it, this is what I get:
    https://www.dropbox.com/s/m56sybg2e1kho64/location%20Capture3.PNG?dl=0
    The location is once again in a dropdown, and the wrong location is highlighted, so you can’t tell which location it is actually for.

    The email I got in response HAS the correct location.
    Your booking request for Taxman Brewing Company – Bargersville is waiting to be confirmed.
    Give us a few moments to make sure that we’ve got space for you. You will receive another email from us soon. If this request was made outside of our normal working hours, we may not be able to confirm it until we’re open again.
    Your request details:
    test
    10 people
    September 23, 2017 1:30 pm

    I can’t see the email the customer got, but I assume it has the correct location.

    It’s important that the correct location show up in the bookings section.
    I would think you would want it to work well with Visual Composer.

    For this website, the client has specific style guidelines, so I have to use Visual Composer.

    Thoughts?

    By the way, because this is a live site, I have to turn the locations plugin off when I am not working on it. If you need to test it, please contact me via this forum and I will turn it on for a short period.

    Meanwhile I will look for workarounds.

    OK, I was wrong. the email notification it sent to me was for the WRONG location. It should have said Taxman – Fortville. That is location 4559
    Taxman – Bargersville is location 4558

    One more thing. There is only one place to set up a confirmation page for the website. How can I redirect users so they get a proper confirmation message on the website? The reservation plugin seems to only have one spot for this.

    Hi @beanthere22,

    It sounds like you’ve configured the shortcode correctly. I’m not sure what the issue is when using Visual Composer, but I know that many users are using Restaurant Reservations with VC.

    You may need someone more technical to dig in to your specific setup and debug the problem, but I’m afraid that’s more support than I’m able to offer. If it is working when you switch to a default theme and deactivate all other plugins, I’d encourage you to reach out to your theme developer to see if they can investigate the issue for you.

    In either case, it really helps if you have a development or staging instance of the website where a developer can tinker without affecting your live site.

    One more thing. There is only one place to set up a confirmation page for the website. How can I redirect users so they get a proper confirmation message on the website? The reservation plugin seems to only have one spot for this.

    If you set a Booking Page in the settings, the form will always submit to this page and the confirmation message will be displayed instead of the form when the booking is successful. If you’d like the users to stay on the same page where the booking form is, don’t set a Booking Page. Then the form will submit to the same page the booking form is on, and the confirmation message will be displayed there.

    Thanks for the insights. Getting closer to working now.

    Next thing. I have set the “Reply to” name and email address in locations to match the respective locations: (examples) “Bob Smith” “location1@domain.com” and “Mary Smith” “location2@domain.com”

    However, the “from” and “reply to” fields of outgoing emails are not reflecting the settings I have made in each location. They always default to the website primary settings.

    I am using the plugin WP-Mail-SMTP. This is a requirement for the email the customer is using. Built in WordPress email just does not work at all.

    By-the-way, now that I have more things running, the locations plugin is great and complements the reservations plugin well. The client likes that they can look at the bookings in the back end by location. I don’t remember reading about that feature, so some additional docs might be good.

    One suggestion, when viewing/editing a booking, the location is shown at the top of the screen, and it shows the correct location, but it is still in a dropdown box. At least for me, that opens someone up to make an error and accidently change the location. I think it might be better to just list the location.

    Hi @beanthere22,

    All emails sent by the plugin use the general WordPress admin email in the FROM header. You can override this with the following micro-plugin if you want:

    https://gist.github.com/NateWr/fbbe6f0eafa7359de161

    Instead, the email should be put into the REPLY-TO header. Are you sure the location-specific email address is not getting set to the REPLY-TO email? I haven’t had any other reports of this issue and I know several users use a SMTP plugin for sending email.

    You can read a bit more detail about how the plugin sends emails here:

    https://wordpress.org/support/topic/e-mails-not-being-send/#post-7562496

    You can read more about the multi-location support in the docs here:

    http://doc.themeofthecrop.com/plugins/restaurant-reservations/user/manage/locations

    > When viewing/editing a booking, the location is shown at the top of the screen, and it shows the correct location, but it is still in a dropdown box. At least for me, that opens someone up to make an error and accidently change the location. I think it might be better to just list the location.

    The purpose of the view is for editing, and a customer might accidentally book for the wrong location, so it’s important that it can still be edited somewhere alongside the other booking details.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Getting a reservation form to only use 1 location’ is closed to new replies.