Support » Fixing WordPress » Getting a page to show up as a home page

  • The theme I’m using will only show a green bar on pages other than the home page, so I want to make http://scandiboard.com.au/scandi-boards/ show up as a home page.

    I tried setting that as the site page in the General Settings but it’s still not showing up when I only enter the domain. How do I get that to show as the default page please?

    This is a single page website.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Peninah

    (@highlight_creative)

    I’m not clear from your post if you did this already, but any page that you set as the “Front page” in General Settings > Reading will become the home page, i.e., it will show up as just the domain. You need to pick an actual page. You create the page, call it “home” or whatever you want, then set it as the front page.

    That’s what I thought Peninah but it’s not working. As soon as I do that it removes the green bar that was at the top of the page. It’s like the designer has made the home page respond differently.

    Peninah

    (@highlight_creative)

    That’s possible.
    Does the theme have any support, or can you see any other examples of sites using that theme? It might give you clues.

    Yes, I’ve already asked at the theme support and they just said that it would cost to get a modification done to get the green banner showing on the home page. So I thought I should be able to get the page I’ve created, that isn’t a home page, set up to automatically show up as the home page. But it’s seeming more like that can’t be done at all.

    Hello, I am having a lil glitch with my site http://www.trevonmpro.com
    I added a home page and edited the Reading setting. However, I now have two homepage templates on the same home page. The default that came with teh theme is above, while my custom designed page is just below. I want the custom designed one alone. Thanks

    Peninah

    (@highlight_creative)

    trevonmpro, you should start a new thread to get answers for your specific problem.

    proverbs, it’s hard to say without being able to see the theme’s dashboard. A theme designer could have done practically anything… it does sound like it has to do with the theme. You might be best off switching themes. (You can test issues by switching to a default WP theme like 2012 or 2013 and seeing if your issues persist, but it sounds like you’re saying your issues are theme-specific.)

    If you decide to pick a new theme, you may find it helpful to google first for reviews, or for lists of quality free themes to select from.

    Thanks Peninah. I’ll leave it as is then. The person I’m doing the site for really wants that theme, it’s just a shame I can’t get the home page to look the same as the other pages, and/or that I can’t get another page to be the home page without losing the green navigation bar at the top.

    Peninah

    (@highlight_creative)

    Doesn’t look like a navigation bar to me. There are no menu links there.

    It definitely is a menu bar. But I’ve removed the links for the site as it’s a one page site and doesn’t need a menu. The title in the green bar is the title for that page though.

    Peninah

    (@highlight_creative)

    Then the theme dev has done something strange to it, because when I check using Chrome’s element inspector, that pops up as an h1 tag, not a menu (as a WP menu should.)

    Yes, I figure they have done something strange. I’ll just have to put up with it I guess as the look is exactly what the owner wants. Thank you for your time anyway. Really appreciate it.

    Peninah

    (@highlight_creative)

    Hope it works out for you

    Thanks Peninah. I figured it out

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Getting a page to show up as a home page’ is closed to new replies.