Support » Plugin: Maps Builder - Google Maps Plugin » Getting a lot of errors

  • Resolved Ali.T.

    (@polaatx)



    Hello, just installed your plugin. Having a lot of trouble to make it work.

    Here’s what happens: as soon as I customize the map or add markers, I can no longer get WP to Update the page anymore. I get the following popup:

    Do you want to leave this page? Changes you made may not be saved.

    See screenshot:

    Is this happening because I’m trying to use some kind feature not offered in the basic version but your plugin is not smart enough to tell me that feature cannot be used and instead it just refuses to update the map?

    This is frustrating. Almost any alteration I make to a basic map triggers this error.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Matt Cromwell

    (@webdevmattcrom)

    That message typically comes up when a change has been made but the post is not saved. It could be various issues with your session or perhaps a conflict with another plugin that integrates with Google Maps in one form or another.

    Please deactivate all plugins besides Maps Builder. If it works as expected then re-activate each plugin one at a time until you see the problem again. Then let us know which plugin caused the error and we’ll dig into it.

    Thanks!

    Hello, Disabling every plugin and reenabling them one by one is going to be time consuming.

    Before I commit to that, would you please take a look at my system info below and see if any of the plugins could a be suspect?

    ### Begin System Info ###

    — Site Info

    Multisite: No

    — Hosting Provider

    Host: DBH: localhost, SRV:

    — User Browser

    Platform: Windows
    Browser Name: Chrome
    Browser Version: 58.0.3029.110
    User Agent String: Mozilla/5.0 (Windows NT 10.0; Wi
    n64; x64) AppleWebKit/537.36 (KH
    TML, like Gecko) Chrome/58.0.302
    9.110 Safari/537.36

    — WordPress Configuration

    Version: 4.7.5
    Language: en_US
    Permalink Structure: /%category%/%postname%/
    Active Theme: Satisfy Child 1.0.7.1491375367
    Show On Front: page
    Page On Front: Homepage (#1383)
    Page For Posts: Unset
    Remote Post: wp_remote_post() works
    Table Prefix: Length: 4 Status: Acceptable
    Admin AJAX: Accessible
    WP_DEBUG: Disabled
    Memory Limit: 64MB
    Registered Post Stati: publish, future, draft, pending, private, trash, auto-draft, inherit

    — Maps Builder Configuration

    Version: 2.1.1
    Upgraded From: None

    — Must-Use Plugins

    — WordPress Active Plugins

    Advanced CSS Editor: 3.0
    Advanced Custom Fields: 4.4.11
    Akismet Anti-Spam: 3.3.2
    BackUpWordPress: 3.6.4
    Child Theme Configurator: 2.2.4.1
    Contact Form 7: 4.8
    Custom User Profile Photo: 0.5.3
    Disable Author Pages: 0.11
    Easy Watermark: 0.6.0
    Enable Media Replace: 3.0.6
    Enhanced Media Library: 2.4.4
    External Links: 6.8.1
    Facebook Open Graph, Google+ and Twitter Card Tags: 2.0.8.2
    Format Media Titles: 0.42
    Google Analytics: 2.1.3
    Google Analytics Dashboard for WP (GADWP): 5.0.0.1
    Instagram Feed: 1.4.9
    Maps Builder: 2.1.1
    Medium: 1.4.0
    NextScripts: Social Networks Auto-Poster: 3.8.2
    Olevmedia Shortcodes: 1.1.9
    Perfect Pullquotes: 1.7.3
    Photoswipe Masonry: 1.2.4
    Regenerate Thumbnails: 2.2.6
    Reveal IDs: 1.5.1
    Secondary Title: 1.9.1
    Simple Author Box: 1.7
    Simple Custom CSS and JS: 3.1
    Simple Drop Cap: 1.2.8
    Simple Google Maps Short Code: 1.3
    Simple Share Buttons Adder: 6.3.5
    Sucuri Security – Auditing, Malware Scanner and Hardening: 1.8.3
    Text Blocks: 1.5.1
    Title and Nofollow For Links: 1.01
    WP Dashboard Notes: 1.0.8.2
    WP Editor: 1.2.6.3
    WP Help: 1.5.1
    WP Statistics: 12.0.6
    WP Tiles: 1.1.2

    — WordPress Inactive Plugins

    Add From Server: 3.3.3
    AJAX Thumbnail Rebuild: 1.12
    Better Search Replace: 1.3
    Content Views: 1.9.8.21
    Envira Gallery Lite: 1.6.1
    Google Analytics for WordPress by MonsterInsights: 6.1.11
    Jetpack by WordPress.com: 4.9
    Media from FTP: 9.62
    Media Library Assistant: 2.53
    Media Library Categories: 1.5.6
    NextGEN Gallery: 2.2.3
    OptinMonster API: 1.1.9
    PanoPress: 1.3
    Photo Express for Google: 0.3.2
    PhotoSwipe Light: 4.1.1.1
    SumoMe: 1.26
    WordPress Media Library Folders: 3.3.7
    WordPress Media Library Folders Reset: 3.3.7
    WordPress Researcher: 2.2.4
    WordPress SEO Tools: 2.2.5
    WP-PhotoNav: 1.2.2
    WP Overlays: 1.0.1

    — Webserver Configuration

    PHP Version: 5.6.30
    MySQL Version: 5.6.28
    Webserver Info: Apache

    — PHP Configuration

    Safe Mode: Disabled
    Memory Limit: 768M
    Upload Max Size: 128M
    Post Max Size: 128M
    Upload Max Filesize: 128M
    Time Limit: 0
    Max Input Vars: 3000
    Display Errors: On (1)

    — PHP Extensions

    cURL: Supported
    fsockopen: Supported
    SOAP Client: Installed
    Suhosin: Not Installed
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /tmp
    Use Cookies: On
    Use Only Cookies: Off

    ### End System Info ###

    • This reply was modified 1 year, 6 months ago by  Ali.T..
    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    I’d suggest deactivating the “Simple Google Maps Shortcode” plugin, and then also — just as a test — deactivating Sucuri, since that error pertains to your logged in session, it’s possible that Sucuri is blocking something and triggering that error.

    I know it can take some time for sure, but because I can’t replicate that issue directly, there’s no way to know what’s happening until we narrow down the possibilities. WordPress is a wild and complex ecosystem particularly when you start adding plugins from so many different developers into the mix.

    Thanks!

    Hello Matt, deactivating the “Simple Google Maps Shortcode” plugin seems to have done the trick. It’s now letting me publish. Thank you.

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Glad to hear, happy to help!

    If you’re enjoying Maps Builder and appreciate our support, we’d love a kind review from you here:
    https://wordpress.org/support/plugin/google-maps-builder/reviews/

    Thanks!

    Hi Matt, I will review your product but I think right now would not be fair to you because I’m simply not competent with your product and because of my ignorance I struggle figuring out your plugin.

    I appreciate your prompt responses and patience with elementary questions.

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Fair enough. Enjoy!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Getting a lot of errors’ is closed to new replies.