Support » Fixing WordPress » Getting a hyphen on my main page title

  • Resolved tami73

    (@tami73)


    Hiya,

    I have tried everything but I can’t seem to get rid of the hyphen showing before my title on the home page, no other page does this. I am using a static page for the home page. Site address is my site

Viewing 14 replies - 1 through 14 (of 14 total)
  • No site link.

    I edited the op to correct the bad url structure

    I looked at the site and do not see a hyphen before the title, only in the middle of the header.

    The hyphen is there, not at the top of the page but if you look at the tab it is opened in. What do you mean you edited the op. How do I do this?

    What do you mean you edited the op. How do I do this?

    I’m a moderator – I edited your post so the link would display.Users can only edit their posts for a short period of time

    try looking in your theme’s header.php for the_title and see if the - is there

    I’m sorry, I can’t seem to locate the problem. If the hyphen is not on the home page, you need to tell me how to get to where it shows.

    Ok, here is a picture of the problem http://www.blackhairinformation.com/hyphen.jpg . I’ve circled the culprit.

    Also looked in the header and I couldnt see a hyphen near the word title.

    Sorry, I was looking in the wrong place – I was looking at the title, not the address bar.

    Now the site is bombed, and I can’t see anything but error messages.

    I was just messing around but the site’s working fine now. Can anyone think of what is causing the hyphen. Even when I delete the title altogether – the hyphen remains!

    I was trying to look at the site to get the name of your theme so I could check its code. Site is still broken. Can you post the name of your theme?

    Cant imagine why you can’t see the site, maybe try clearing your cache? Ive tried on 2 pc’s and my mobile and all working fine! I’m using Branford Magazine theme. Can anyone help with the hyphen issue. It’s not major but its quite irritating!

    The hyphen is at line 21 of header.php:

    wp_title(''); echo ' - ' . get_bloginfo('name');

    Just delete it:

    wp_title(''); echo '  ' . get_bloginfo('name');

    I still can’t connect to your site through the link at the top of the page, but that is a moot point now.

    Thank you so much! It worked!!

    You are welcome! Now, please use the dropdown at top right to mark this topic ‘Resolved’.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Getting a hyphen on my main page title’ is closed to new replies.