Support » Fixing WordPress » Getting a 404 when I try to auto update a plugin

  • Resolved Strictly Software



    I am using the latest software and I haven’t had to update a plugin for a while now but tonight I noticed Jetpack was out of date on one site and not on another (both on same server, same plugins and behind CloudFlare with WP Super Cache – which has been having issues lately??)

    Anyway when I try to auto update a plugin on this one site the following happens.

    1. The password field is full to the brim with *********** on my other site I just have the same number of **** as the word beneath it (inspect and change type=”password” to “text” to prove it.

    2. When I hit update it goes straight to a /404 page e.g

    3. It then shows a greenish page that says “sorry we couldn’t find what you were looking for” here are some suggestions. A cloudflare page.

    4. I have asked Cloudflare about this but I have had problems before with Omnisearch being enabled causing similar issues and also I cannot use any JetPack stats as the URL /wp-admin/admin.php?page=stats just takes me to WP-O-Matics dashboard.

    I have checked WP-O-Matics source code and CANNOT see anything about going to that URL.

    Is this to do with something WP has done or Cloudflare or both. The password box full to the brim with ****** on one site but not the other suggest something with WP is going on.

    Thanks for your help


Viewing 10 replies - 1 through 10 (of 10 total)
  • It wouldn’t be the first update to cause problems 😉

    1. Use FTP to access your site
    2. rename all plugins by putting a ‘0’ in front of each plugin -folder;
    3. Check if the access / ‘normal functioning’ has been restored
    4. If so: one-by-one, remove the ‘0’, checking every time to see if the problem re-occurs.
    5. when the problem re-occurs, you’ve found the source of the problem; Delete and find a similar plugin that works with your site
    6. alternatively: FTP:Delete; Then download and install / activate a NEW version of the problematic plugin and see if this works.

    Instead of ftp, use the webaccess dashboard functions provided by the webhost.
    This usually is not as versatile and more cumbersome.

    == == == !!NOTE!!
    It may also be that the ORDER in which these plugins are updated / installed causes issues.

    Check if this works:

    • FTP: rename all plugins, except the one that needs updating
    • use the dashboard to update that plugin
    • FTP: remove the temporary rename from the plugins
    • refresch browser <CTRL-F5>
    • check results…


    Okay thanks I will try that.

    I am used to FTP and have no trouble using it at work or at play so to speak but it was nice just being able to upgrade from the dashboard.

    Both sites have exactly the same WP, plugins and versions installed so I am wondering why one site has a password box full of ********** and the other just the same amount as the word underneath.

    That seems strange on it’s own – ideas.


    Right I have found the cause of the problem

    If you are using Cloudflare they have an “app” called “SmartErrors” which says

    SmartErrors dynamically replaces your website’s dead-end error pages, like a 404, with a custom search results page tailored to your site’s content, resulting in increased visitor engagement and decreased bounce rates.

    However I had one site using this (the one that DIDN’T allow me to do FTP auto plugin updates) and one that didn’t (which worked!”)

    So I don’t know if it’s a Cloudflare issue or a WP issue but if it’s on it’s an issue!

    great detective work!

    More like I spend too much time debugging and trying to get the bottom of bugs than I should!

    I don’t know if its a WordPress bug or a CloudFlare one but I guess you need to talk to each other about it 🙂



    Please don’t forget to mark the thread as ‘resolved’ [in the right sidebar]

    Is it actually resolved though?

    The SmartErrors app OR the WP plugin FTP admin + something with Cloudflare IS still causing a problem and hasn’t been fixed even though both sides are working on it.

    I have marked it as resolved though even though I think when the bug STOPS happening then it should be resolved – pedantic I know!


    “2. When I hit update it goes straight to a /404 page e.g

    3. It then shows a greenish page that says “sorry we couldn’t find what you were looking for” here are some suggestions. A cloudflare page.”

    The SmartErrors app only triggers when the page that is being requested is returning a 404. It still means there’s a 404 on your server that you need to address (try turning off the app & you should be seeing a Page Not Found error when you access that page with the app off).


    No when I turn off the SmartErrors app in CloudFlare apps, the WordPress plugin automatic update tool works again normally. No 404 page and there has never been a 404 page shown when I have tried to use this core WP Admin tool to update plugins by FTP from within the admin area of the site.

    Remember this is core WordPress code not 3rd party plugin code and it has been around and working for a very long time now.

    The problem was that the update plugin page showed the usual username & password box and the option for FTP / SFTP to your server but when you hit the submit button instead of the form submitting to the page that lists all the commands being run e.g

    de-activating old plugin
    removing old plugin code
    download plugin from …..
    unzipping plugin
    installing plugin
    activating plugin

    return to plugin list (link)

    It was just going to

    Therefore it is either WordPress having a bad re-action with SmartErrors or SmartErrors causing the problem with WP. No plugins on my site have changed recently (I never add new ones due to all the madness and hell it causes me – just an upgrade to core WP code causes nightmares 90% of the time for me) – the only other plugin I can think of that would cause such an issue is JetPack (another Automatic plugin) as this often causes issues and I have often complained about their share options (protocol JS errors https to http), Omisearch causing errors and many more issues in these forums. So maybe Jetpack caused a problem when it was upgraded – a lot of people have complained about Jetpack causing issues – I cannot even get it to show me stats for my site I get another plugins dashboard instead.

    However I can guarantee you 100% that when I turn SmartErrors off the problem goes away and 100% that it comes back when I turn it on again.

    However I haven’t had it on for a few days at least now (probably since the date of my previous post due to the problem) so maybe CloudFlare or WordPress have fixed whatever issue was causing it to happen.

    I also posted this issue on the CloudFlare support forum and they said they were looking into it.



    “I also posted this issue on the CloudFlare support forum and they said they were looking into it.”

    Great. Thanks for the update!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Getting a 404 when I try to auto update a plugin’ is closed to new replies.