Support » Theme: Karuna » Getting a 404 for the genericons

  • Hi
    I’m getting a 404 (Not Found) for genericons.css when I activate the theme,
    and I see an empty square instead of the icon in the menu.

    In functions.php:
    wp_enqueue_style( 'genericons', get_template_directory_uri() . '/genericons/genericons.css', array(), '3.4.1' );

    But the genericons.css is in this folder: \assets\fonts\genericons

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi @poena!

    I see exactly what you mean – specifically in the menu, the icon indicating the presence of a dropdown menu is a blank character.

    It looks like the path to the genericons stylesheet isn’t set correctly. I’ll file a bug report to have that fixed.

    Two workarounds for now – first and easiest, install and activate the Jetpack plugin. That should get the genericons working properly through the plugin’s styles.

    Second, if you’d like, you can set up a child theme to fix the path.

    In the functions.php file of your child theme, paste the following:

    function genericon_fix() {
        wp_dequeue_style( 'genericons' );
        wp_enqueue_style( 'genericons-fixed', get_template_directory_uri() . '/assets/fonts/genericons/genericons.css', array(), '3.4.1' );
    }
    
    add_action( 'wp_enqueue_scripts', 'genericon_fix', 12 );
    

    That removes the bad path and replaces it with the correct one.

    Thanks so much for pointing this out! We’ll let you know when it’s fixed within the theme directly 🙂

    Theme Author Automattic

    (@automattic)

    Howdy!

    Thanks for pointing out this bug. We’ve fixed Karuna so it points to correct path for Genericons and have resubmitted it to WordPress.org for review. Hope this helps. 🙂

    Cheers,
    Caroline

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Getting a 404 for the genericons’ is closed to new replies.