Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @atomicbong,

    Could you please explain your setup a bit more because I’m not sure where that URL should be pointed to and how it was set up?

    If I check your site and go to My Account > Admin Back End it’s loading the login form fine and that URL seems to me like masked login URL so I’m not sure how is the one that you shared used?

    Cheers,
    Predrag

    Thread Starter atomicbong

    (@atomicbong)

    The login page loads fine.
    I am using WP Ultimo for a WAAS set up.
    This is one of their sign up links for a plan to create a subsite.

    It was working fine earlier. But now it’s showing 404.

    I think it has something to do with the sign up process.
    There was a change recently right?

    Thread Starter atomicbong

    (@atomicbong)

    Hi,

    Just following up regarding this.

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @atomicbong ,

    Did you disable Defender or downgraded it to the previous version? I’m checking that link you sent and there is no 404 error, I can procceed with signup and the whole process of getting a site.

    kind regards,
    Kasia

    Thread Starter atomicbong

    (@atomicbong)

    Hi,

    Yes, I disabled Defender and I’m trying to use a less secure alternative at the moment as it was stopping my daily scheduled tests.

    Thread Starter atomicbong

    (@atomicbong)

    Please use my dev environment’s temp login:
    https://ews.ewx.mybluehostin.me/smdev/sm-secure-login
    Username: admin
    Password: pass

    There are only two plugins: WPUltimo and Defender.

    It uses wp-signup to sign up users and create subsites in the multisite network

    Use incognito and try this user sign up link:
    https://ews.ewx.mybluehostin.me/smdev/wp-admin/admin-ajax.php?skip_plan=1&plan_id=50&plan_freq=1&action=wu_process_plan_select

    It goes to the default 404 page.
    On deactivating the plugin, the sign up works fine.

    It was working fine in the previous version. 2.3.0
    It breaks in v 2.3.1

    Please advise.
    You can delete the plugin and install your dev builds too, to test.
    That’s not an issue.

    Thanks,

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @atomicbong

    Please never post any access credentials here. This is a publicly available forum and that information is now publicly available. I can’t remove/mask it even if I wanted to and even if it’s testing/staging environment it’s a huge security risk to publicly post such access information.

    Please change at least password there as soon as possible.

    As for the issue itself. Yes, there were changes related to signup as not everything was masked that should be. Now the default “wp-signup.php” is also masked but WP Ultimo (that signup URL that you provided) is by default using that “wp-signup.php”.

    So, when Login masking is active, WP Ultimo actually sends you to non-existing (masked) “wp-signup.php” page and that results in either “this feature is disabled” option (if redirect for login masking is disabled in Defender) or with “404” page (if it’s enabled in Defender and set to redirect to 404).

    Solution for this is actually “built-in” into WP Ultimo. On “Network Admin -> WP Ultimo -> Settings -> Network Settings” page you’ll find two options:

    “Registration URL” and “Login URL”

    and you need to set hem to some slugs different than default ones and not including words like “Login”, “signup”, “admin” and similar.

    For example, I’ve set registration URL to “mysiteplans” and that makes it work as expected even with Login Masking (and redirect) enabled in Defender.

    Best regards,
    Adam

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello @atomicbong

    I’m closing this topic due to recent inactivity.
    Feel free to post back any update and we can re-open it and carry on troubleshooting.
    🙂

    Thank you,
    Dimitris

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Getting 404’ is closed to new replies.