Support » Plugin: Hustle - Email Marketing, Lead Generation, Optins, Popups » GetResponse Integrate not working

  • Resolved adrian33000

    (@adrian33000)


    I am trying to integrate Hustle with GetResponse. I have followed your Doc’s Guide but no matter how I do this sign-ups are not being sent to GetResponse.

    I have checked the error result which says this:

    “`Account name: ibp9pm7d09zso156jhf9cmzgvs5boh0p (6169c6028c9785.44116690)
    Info: Hustle_Get_Response_Form_Hooks::add_entry_fields() Failed to add member – Bad Request{“httpStatus”:400,”code”:1000,”codeDescription”:”General error of validation process, more details should be in context section”,”message”:”Custom name is forbidden”,”moreInfo”:”https://apidocs.getresponse.com/en/v3/errors/1000″,”context”:[],”uuid”:”3081b21b-96fd-40da-96f7-e6e00df2501c”}
    List name:420b original (zEsDL)`”

    The list name is correct

    ibp9pm7d09zso156jhf9cmzgvs5boh0p is the API provided by GetResponse and works as it was used on another pop-up

    I have no idea what (6169c6028c9785.44116690) is?

    I do need to get this working. It did with Poptin but I prefer Hustle if I can get it to work.

    Any help to do this appreciated.

    Thanks

    • This topic was modified 2 months, 3 weeks ago by adrian33000.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter adrian33000

    (@adrian33000)

    As a follow-up to the above, I have been in touch with GetResponse. They have responded as follows:-

    I have checked the API logs and it seems that the error is caused by the fact that you cannot create a custom field called 'name', here's the log:
    
     {'name':'name','type':'text','hidden':false,'values':[]} 
    
    Please try name1 as name is reserved already.

    Maybe this might help you to resolve this issue??

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @adrian33000

    I hope you’re well today and I’m sorry for the delay!

    Yes, this is definitely related to the fact that the “name” is “restricted” by GetResponse for internal use.

    This is something that is already known to our Hustle Team and our developers will implement improvement for that with one of future releases but until then it should be easy to resolve by just… changing the filed name on the form.

    it seems that you do have a field on form titled “name”. You would need to just change the field label to, for example, “First name” or “Your Name” or something similar. As long as it’s not just “Name” (case insensitive so “Name” and “name” are actually the same) it should be fine.

    Would you give it a try, please?

    Best regards,
    Adam

    Thread Starter adrian33000

    (@adrian33000)

    Hi Adam

    Thanks for the reply. I think I have tracked down the element where “name” had been used and have edited this. So I am now waiting to see if the next sign-up is correctly integrated with GetResponse. I will update this thread in due course.

    Thread Starter adrian33000

    (@adrian33000)

    Hi Adam

    Update. I had edited the Labels in the email fields to that suggested by GetResponse to name1 for the First name and name2 for the second name and this appears to have allowed the integration to work successfully as the last sign-up shows a Yes for the “Data sent to integration” section.

    Hopefully, this will now continue to work. Unfortunately, I could not verify this in the GetResponse mail list as the person who signed up was already on that list.

    Thanks for your help. Might be worth amending the instructions in your documentation to mention this requirement until such time as you can issue a release to resolve this issue.

    I had tried using “firstname” and “secondname” in the email fields but that stripped out the names altogether and also caused a second error notice as it is not possible to add a subscriber without at least one name. As the Names are obligatory items on the form the subscriber must have included them but they were obviously deleted when recording them. So it seems the label must have “name” to work.

    Kind regards

    Adrian

    Thread Starter adrian33000

    (@adrian33000)

    Hi Adam

    Further update. I have just reviewed the first new integration that has been sent via the plugin. Unfortunately, although the email is displayed the subscriber’s names do appear even though on the custom fields area the names are included in the “name1” and “name2” spaces. So it seems that although using name1 or name2 as recommended by GetResponse to avoid the conflict with the reserved word name it is still causing a problem with correctly adding the subscriber to the list by only enabling the email to be recorded.

    If you have any suggestions to resolve this I would appreciate it.

    Thanks

    Adrian

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @adrian33000

    I found a similar report and it worked when the field was first_name https://monosnap.com/file/Q64J1qDqky8BGRNZ7T1PlawsCFdyp9

    Can you check if makes any difference?

    Best Regards
    Patrick Freitas

    Thread Starter adrian33000

    (@adrian33000)

    Hi Patrick

    Thanks for this. I have edited and it does seem to work for the First Name field but when I tried second_name for the second name it failed to pass the data. I am now trying first_name for both the First and Second name fields to see if that will work but at least having a “First” name recorded is better than none. I will let you know if this workaround resolves the both name’s issue.

    Kind regards

    Adrian

    Thread Starter adrian33000

    (@adrian33000)

    Hello

    I have now managed to find a solution to this problem. To enable the full integration you appear to need to enter first_name as the data in the Name field and last_name for the Second Name assuming you do want to obtain both names. This enables GetResponse to correctly record the First and Second name along with the email details in the subscriber’s mailing lists.

    It might be worth you updating your Docs for GetResponse integration to clarify this for any other Hustle plugin user to avoid the hassle of experimenting to find a workable solution.

    Kind regards

    Adrian

    Plugin Support Nebu John – WPMU DEV Support

    (@wpmudevsupport14)

    Hi @adrian33000,

    Thank you for bringing this to our notice.

    I have updated the Hustle team regarding the same and the documentation team to consider adding this into our documentation.

    I am marking this issue are resolved, feel free to open a new thread if you need any further assistance.

    Kind Regards,
    Nebu John

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.