get_posts in meta box dropdown not showing latest posts (3 posts)

  1. dagfooyo
    Posted 3 years ago #

    Hi there. I’ve got a metabox I set up using WPAlchemy that allows authors to add a link to an associated post. It’s been working fine for months but now for some reason the dropdown with the appropriate posts isn’t updating. Here’s the code in the custom post meta php file:

    <?php $mb->the_field(‘product_video_ID’); ?>
    <select name=”<?php $mb->the_name(); ?>”>
    <option value=”">None</option>
    global $thispost;
    $myposts = get_posts(‘numberposts=5000&offset=1′);
    foreach($myposts as $thispost) :
    if (in_category(“Product Videos”, $thispost)) {
    <option value=”<?php echo $thispost->ID; ?>” <?php $mb->the_select_state($thispost->ID);?> ><?php echo get_the_title($thispost->ID); ?></option>
    <?php } ?>
    <?php endforeach; ?>
    <?php setup_postdata($thispost);?>

    I tried adding a couple test posts in the Product Videos category and they didn’t show, either. I commented the lines that filtered for that category and the Meta box dropdown updated to show every post… except the one I wanted and the new test ones. Anybody have any idea what might be going on? Is there some part of the machinery here that isn’t updating that I should fix? Thanks so much!

  2. dagfooyo
    Posted 3 years ago #

    This is still happening. Still can't figure out why. Any thoughts would be very very much appreciated. Thanks!

  3. dagfooyo
    Posted 3 years ago #

    Never mind, I figured it out. The issue was "numberposts=5000" - the blog just exceeded 5000 posts so new ones weren't showing up. I fixed it by changing to "numberposts=-1" which tells WordPress to search through all posts.

Topic Closed

This topic has been closed to new replies.

About this Topic