get_header and get_footer break design with weird characters (4 posts)

  1. Trollivier
    Posted 7 years ago #

    Hello there.

    I'm creating my own theme here, and I have a very weird problem.
    Any time I use "get_header()" or "get_footer()" function, there is a weird spaces appearing in my design. I tried to find what's causing this... and I kinda found it.

    In the source file from Explorer, it gives me a small rectangle character before the code that is included. In Firefox source file, it's a very very small dot that's there.

    In the case of the get_header, the character appears before the doctype, causing the design to break in IE.

    I asked a programmer at my job, he told me it could be some weird thing coming from the file delimiters. So I tried to include the entire code from header.php into index.php, and the problem was solved.

    So i could go without using header.php, but that would be kinda dumb... i'd really like to use get_header(). Anyone knows what the problem is?

    Thank you very much!

  2. Trollivier
    Posted 7 years ago #

    Any ideas anyone? :S

  3. Trollivier
    Posted 7 years ago #

    Any ideas?

  4. miquel_909
    Posted 7 years ago #

    Trollivier, I'm having the same problem, but your workaround didn't work for me

    See: http://wordpress.org/support/topic/272302?replies=5#post-1078884

    Have you already solved it ? If so, could you explain it here ?


  5. miquel_909
    Posted 7 years ago #

    I've found the solution here, maybe it can help you:


Topic Closed

This topic has been closed to new replies.

About this Topic