WordPress.org

Forums

WP Security Audit Log
[resolved] get_called_class failed to call because PHP 5.3.0 required (6 posts)

  1. sergtk
    Member
    Posted 1 year ago #

    After upgrade plug in does not work any more becuase PHP 5.3.0 is required.

    I received following error:

    Fatal error: Call to undefined function get_called_class() in path/wp-content/plugins/wp-security-audit-log/classes/DB/ActiveRecord.php on line 269

    It seems this is incompartible with WP, which requires 5.2.4 (http://wordpress.org/about/requirements/)

    Is it possible to use plugin with 5.2.4 ?

    Thanks.

    https://wordpress.org/plugins/wp-security-audit-log/

  2. WPWhiteSecurity
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Sergtk,

    Thank you for using our plugin.

    Please note that there is no incompatibility with WP, i.e. if WP supports an older version of WP does not mean we have to support it.

    There are several reasons why we are not supporting PHP versions older than 5.3, most of which are security related. You can read a detailed answer to why we are not supporting PHP versions older than 5.3 in this support ticket.

    Should you need assistance switching your PHP version to a newer version, just contact your hosting provider or let us know and we will check for you :)

    Trust the above answers your query and clarifies this issue.

  3. sergtk
    Member
    Posted 1 year ago #

    Now it is clear what is going on.

    When I say incompatibility I mean that I need something special for plugin after I installed WP.

    Plugin works fine with PHP 5.3. Ofcourse I don't mean that plugin does not work with WP at all :)

    Thanks for answer.

  4. WPWhiteSecurity
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Sergtk,

    Ah ok now I got your point. No problem at all and let us know should you have any further queries.

  5. cl170319
    Member
    Posted 1 year ago #

    Плагин не был активирован, потому что он вызвал фатальную ошибку

    Fatal error: Call to undefined function get_called_class() in /home/ninakovale/domains/nina-kovalencko.com/public_html/wp-content/plugins/wp-security-audit-log/classes/DB/ActiveRecord.php on line 304.Не могу решить эту проблему

  6. WPWhiteSecurity
    Member
    Plugin Author

    Posted 1 year ago #

    Hi there,

    It seems you are having the same issue, i.e. you are using an old version of PHP. In that case drop us an email on plugins@wpwhitesecurity.com and we can provide you details on how you can update your PHP version.

    Thank you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Security Audit Log
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.