• Resolved darylpittman

    (@darylpittman)


    This error started appearing in php_errorlog in my site’s NETWORK folder, starting Jan 11.

    Currently running FooGallery 1.6.11 on WordPress 4.9.9

    It is interesting to note the error started on Jan 11. My update to FG 1.6.11 was Jan.2.

    Everything appears to running appropriately on the front end.

    [13-Jan-2019 09:02:43 UTC] PHP Fatal error: Uncaught Error: Call to undefined function get_blog_list() in ../wp-content/plugins/foogallery/freemius/includes/class-freemius.php:12337
    Stack trace:
    #0 ../wp-content/plugins/foogallery/freemius/includes/class-freemius.php(12406): Freemius::get_sites()
    #1 ../wp-content/plugins/foogallery/freemius/includes/class-freemius.php(16744): Freemius->get_blog_install_map()
    #2 ../wp-content/plugins/foogallery/freemius/includes/class-fs-plugin-updater.php(122): Freemius->has_any_active_valid_license()
    #3 ../wp-content/plugins/foogallery/freemius/includes/class-fs-plugin-updater.php(72): FS_Plugin_Updater->filters()
    #4 ../wp-content/plugins/foogallery/freemius/includes/class-fs-plugin-updater.php(59): FS_Plugin_Updater->__construct(Object(Freemius))
    #5 ../wp-content/plugins/foogallery/freemius in /home/laserima/laserimagenc_dot_com/wp-content/plugins/foogallery/freemius/includes/class-freemius.php on line 12337

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support phillcoxon

    (@phillcoxon)

    Hi Daryl,

    Are you able to tell us what version of PHP you are using?

    @bradvin – are you able to review this for Daryl please?

    Ha, ha (In a good way!)

    “Are you able to tell us what version of PHP you are using?” is the most relevant question I’ve heard all day! 🙂

    According to my CPanel (for SiteGround) trip to phpMyAdmin, the Web server PHP version is 5.6.30 …

    Yet, a System Status report of my WordPress site says this:

    ### PHP ###

    Version: 7.0.33 ✘ Recommended: PHP 7.1 or higher.
    Memory Limit: 768M
    Maximum Execution Time: 120
    Maximum File Upload Size: 128M
    Maximum File Uploads: 20
    Maximum Post Size: 128M
    Maximum Input Variables: 3000
    cURL Enabled: Yes (version 7.59.0)
    OpenSSL: OpenSSL 1.0.2q 20 Nov 2018 (268443935)
    Mcrypt Enabled: Yes
    Mbstring Enabled: Yes
    Loaded Extensions: Core, date, libxml, openssl, pcre, sqlite3, zlib, bcmath, bz2, calendar, ctype, curl, dba, dom, enchant, hash, fileinfo, filter, ftp, gd, gettext, gmp, SPL, iconv, session, intl, json, ldap, mbstring, mcrypt, standard, mysqli, pcntl, mysqlnd, PDO, pdo_mysql, pdo_pgsql, pdo_sqlite, pgsql, Phar, posix, pspell, readline, Reflection, imap, shmop, SimpleXML, soap, sockets, exif, sysvmsg, sysvsem, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, cgi-fcgi, memcached, ionCube Loader, Zend OPcache

    Thanks for looking at this.

    Let me know if this is irrelevant or need more information.

    Plugin Author bradvin

    (@bradvin)

    @freemius – have you seen this error from the SDK before?

    Hi @darylpittman,

    We did some digging, and the only case in which the SDK calls that function is when the get_sites() and wp_get_sites() core methods are not defined. But, get_sites() is supported from WP 4.6 and higher, so it should be available on your version 4.9.9. I also looked at the execution logic and the function is included in ms-blogs.php which is required in wp-settings.php before the inclusion of any plugins.

    So frankly, I don’t understand how this situation is even possible unless there’s something custom that changes the expected result of is_multisite() when wp-settings.php is executed.

    Do you have any MU plugins installed? or anything special in the environment?

    Folks, thanks for looking into this. I just checked the same error log and this situation seems to be last recorded on 1/13 which is about the time I noticed the error logged. Everything seems to be operating as expected. I ran into this when I was, out-of-the-blue, looking at error logs. I occasionally check them out because I found one had grown into a huge monster, if you get my drift.

    I passed this along as a means of making the product better.

    I don’t know of any “must use”? plugins. The developer who built our site between 2014-2016 did very expertly add custom scripts, though.

    Plugin Support phillcoxon

    (@phillcoxon)

    Hi @darylpittman,

    If I interpret your response correctly – the issue is now resolved and you haven’t seen the error since 13 Jan. That’s great.

    Please drop us a line again if you have any more concerns.

    Thanks in advance,

    Phill

    That’s a big 10-4, good buddy!

    I received an automated WordPress email re: the same error described above. WordPress version 5.2.2, PHP 7.2, FooGallery 1.7.6. Not sure if this is something you’ve been able to figure out in the interim since the last post. Cheers.

    I’m getting the email from WordPress also. I forwarded it to support, but got no reply yet. I just got the email again. The subject line is Your Site is Experiencing a Technical Issue
    and then it goes on to say:

    Howdy!

    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

    In this case, WordPress caught an error with one of your plugins, FooBox Image Lightbox.

    Error Details
    =============
    An error of type E_ERROR was caused in line 12628 of the file [site url removed]public_html/wp-content/plugins/foobox-image-lightbox/freemius/includes/class-freemius.php. Error message: Uncaught Error: Call to undefined function get_blog_list() in [site url removed]public_html/wp-content/plugins/foobox-image-lightbox/freemius/includes/class-freemius.php:12628
    Stack trace:
    #0 [site url removed]/public_html/wp-content/plugins/foobox-image-lightbox/freemius/includes/class-freemius.php(12697): Freemius::get_sites()
    #1 [site url removed]/public_html/wp-content/plugins/foobox-image-lightbox/freemius/includes/class-freemius.php(17035): Freemius->get_blog_install_map()
    #2 [site url removed]/public_html/wp-content/plugins/foobox-image-lightbox/freemius/includes/class-fs-plugin-updater.php(122): Freemius->has_any_active_valid_license()
    #3 [site url removed]/public_html/wp-content/plugins/foobox-image-lightbox/freemius/includes/class-fs-plugin-updater.php(72): FS_Plugin_Updater->filters()
    #4 [site url removed]/public_html/wp-content/plugins/foobox-image-lightbox/freemius/includes/class-fs-plugin-updater.php(59): FS_Plugin_Updater->__construct(Object(Freemius))
    #5 [site url removed]/public_html/wp-content/plugins/foobox-image-lig

    Site seems fine.
    Thanks!

    OP here,

    I’m getting the automated emails, also. Our site seems to be working as expected.

    Just updated Development site to 2.7.2. It will be a couple of days before I update Production site which is from where I get the automated emails.

    Will stay tuned!

    After review, here are my error details …

    Error Details
    =============
    An error of type E_ERROR was caused in line 12628 of the file /home/laserima/laserimagenc_dot_com/wp-content/plugins/foobox-image-lightbox-premium/freemius/includes/class-freemius.php. Error message: Uncaught Error: Call to undefined function get_blog_list() in /home/laserima/laserimagenc_dot_com/wp-content/plugins/foobox-image-lightbox-premium/freemius/includes/class-freemius.php:12628
    Stack trace:
    #0 /home/laserima/laserimagenc_dot_com/wp-content/plugins/foobox-image-lightbox-premium/freemius/includes/class-freemius.php(12697): Freemius::get_sites()
    #1 /home/laserima/laserimagenc_dot_com/wp-content/plugins/foobox-image-lightbox-premium/freemius/includes/class-freemius.php(17035): Freemius->get_blog_install_map()
    #2 /home/laserima/laserimagenc_dot_com/wp-content/plugins/foobox-image-lightbox-premium/freemius/includes/class-fs-plugin-updater.php(122): Freemius->has_any_active_valid_license()
    #3 /home/laserima/laserimagenc_dot_com/wp-content/plugins/foobox-image-lightbox-premium/freemius/includes/class-fs-plugin-updater.php(72): FS_Plugin_Updater->filters()
    #4 /home/laserima/laserimagenc_dot_com/wp-content/plugins/foobox-image-lightbox-premium/freemius/includes/class-fs-plugin-updater.php(59): FS_Plugin_Up

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.