Support » Fixing WordPress » get_allowed_mime_types() return false (no Mime Type present at all)

  • Hello!
    I’m experiencing a weird issue with Mime Types on WordPress 3.3.2.

    I was trying to upload a zip file, and it was possible on the local version of the website I’m working on. But not on the online version of the same website. Same theme, but in local is a single site, online is part of a network (multisite).

    I later discovered that if I run get_allowed_mime_types() in local, I get a well endorsed list of allowed mime types.

    But when I run it on the living version, I get an empty array. Or false. Or “”. Can’t say precisely. But, the weirdo is that no Mime Type is present. In fact, I cannot upload pictures, or any other kind of file.

    Did it happen to any of you before? I guess I could reconstruct the list, but I would like to understand how this could happen in the first place, before to proceed.

    Any clue?

    Thanks in advance, best,

Viewing 1 replies (of 1 total)
  • Something else funny happens, indeed.

    I’ve uploaded a file (a zip) and the file name changed, at the end, just before the extension, it has been added a _ somehow.

    Example, original file name “”

    File name after upload “”

    I can see that from the Media/Edit and when I try to download it. Then, the download goes smooth. But the _ at the end of the file name, I’ve never seen that before.

Viewing 1 replies (of 1 total)
  • The topic ‘get_allowed_mime_types() return false (no Mime Type present at all)’ is closed to new replies.