Support » Fixing WordPress » Get WordPress out of my url

Viewing 6 replies - 1 through 6 (of 6 total)
  • No, there is no simpler ways, only more difficult ways. If you did set up a sort of redirect, you would still see the “/wordpress” after the redirect in the address bar.

    what’s the easiest way to move these files without messing up everything?

    My selfhosted blog does not show any /wordpress ending. There’s no need for it. Just install WP into the highest level folder on the server. The same place you’d normally put the index.html file if you had standard web pages on your site. You have few enough posts that even if you lose anything, it’s easy enough to reload.

    Also, I suggest you change your permalink structure, the p=12 thing sucks, in my opinion. Go to Settings > Permalinks and choose Numeric or Month/Name as you wish. It makes for better search engine results and bookmarking. Again, sooner is better before you have too many posts.

    Just my two cents.

    For the OP:
    1. Read the Documentation – it always helps: Giving_WordPress_Its_Own_Directory 9obviously, you skip #6)

    2. The easiest way to move (in your case)
    a) – admin > Settings > General
    b) – change to two URL values to the new location (root) and save
    c) – disregard the error message
    d) – (don’t try to see your blog)
    e) – move all the WP files and directories to the root
    f) – you may need to update your permalinks



    Just thought I’d revisit this post even though it’s been resolved for months. The easiest way to get wordpress out of url is just to re-install, there’s now a prompt which asks you if you’d like to have wordpress in the url. So please don’t go tweaking the root etc, especially if your blog is new. Just re-install and pay attention to the prompts…

    In order to re-install, I assume I have to uninstall first. (yes, no?)
    Then when I re-install, will the blogs I’ve created so far appear? Or do I need to save them (in word?) and recreate them again? I don’t have many so it’s not an issue at this point. Thanks for your help!!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Get WordPress out of my url’ is closed to new replies.