Support » Plugin: WooCommerce PayPal Checkout Payment Gateway » Get warning when enable credit card in Express Smart Button

  • Resolved 2bulbs

    (@2bulbs)


    We were using this plugin without any trouble for over six months already.
    Thanks!!

    Recently, there was an update with the Express Smart Button function released.

    However, every time we try to remove “credit card” from the “Hide Funding Method(s)”, the warning message shows up as below:

    Warning: in_array() expects parameter 2 to be array, string given in /public_html/wp-content/plugins/woocommerce-gateway-paypal-express-checkout/includes/class-wc-gateway-ppec-cart-handler.php on line 280

    Any idea how to solve this issue?

    Look forward to hearing from you soon.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Paul Dechov

    (@pauldechov)

    Hi 2bulbs,

    A fix will be included in the next release (due next week), but in the meantime, the warning can be avoided by setting “Hide Funding Method(s)” to “PayPal Credit”, which appears to be unsupported for your store in any case.

    Thank you for reporting this – hope that helps!

    Paul

    Thanks for the quick and helpful response!
    It works now.

    Best regards,
    Ken

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Get warning when enable credit card in Express Smart Button’ is closed to new replies.