Support » Fixing WordPress » "GET to /wp-admin/post.php not supported."

  • Hello. I was just trying to make a new post on my site ( when this error showed up.

    Method Not Implemented

    GET to /wp-admin/post.php not supported.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I googled a little and there is a file called .htaccess involved. So, I went to the root of wordpress where is was supposed to be, but I found nothing, even when selecting the option “show hidden files”. Then, I thought “well, if it doesn’t exist then let’s create one” and I did, many times, with different codes I found all over the Internet. The result? None of them worked, most of them did nothing and some even made the website crash.

    This is the second time this happens, last time was months ago in a similar situation: making a post with a lot of content (video, featured image, tags, category, all kind of fonts, hyperlinks, etc)

    So, how do I fix this? As you can guess, I have no relation with web development, so try to make the solution as simple as possible.


Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi Hopehornby,

    I came across your post also looking for answers to a similar question. However, I think that you have been led in the wrong direction. It seems to me that what the error message is telling you is that the function GET in the post.php page under wp-admin is not supported by either your version of WP or the plug in version was written for an earlier version than yours. Therefore, you need to take a look at the code within post.php or go through the tedious task of deactivating every plug in that you might have installed right before this error happened (or all of them, if you don’t remember which one and then activate them one by one until you find the culprit)

    Method Not Implemented

    GET to /wp-admin/post.php not supported.

    Although it is unlikely that the error is being generated by your .htaccess file, you might need to find it under your hosting server CPanel. Some of them have direct link to the htaccess where you can view and edit the file. Another way is to use your CPanel file manager to look at the root of your site (account). It should be there. If you have created (or a plug in has) a separate htaccess under your WP directory, then you should also be able to see it under that directory via your online File Manager. There are some plug ins that do get into some code they should not (like the Nova QR) and they are so well “hidden” you have to do some “coding tricks” to get them off your pages. Others, modify your wp-config and htaccess and you can get locked out. I’ve had both experiences. Fortunately, I know a bit of coding and my son is a Sr. Software Engineer and Web developer. He helps me out and educates me when possible so I can fix my own messes. 🙂

    Anyway, I hope this helps you a bit. The people at this forum are pretty eager to help out so if this one doesn’t help you, someone else’s will, especially a developer.

    Good luck

    Hello, Soul. I ended up contacting the hosting since I remember this happened long time ago with the same hosting on an almost-fresh WP install. So, they have fixed it, but I don’t know what it was.


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘"GET to /wp-admin/post.php not supported."’ is closed to new replies.